Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Get rack from rails/rack.git. Introduce ci-only deps.

  • Loading branch information...
commit a584b4c13dc12ba102182e914e428ea6730cfef2 1 parent 457940e
@jeremy jeremy authored
Showing with 21 additions and 15 deletions.
  1. +21 −15 Gemfile
View
36 Gemfile
@@ -1,22 +1,28 @@
clear_sources
source 'http://gemcutter.org'
+gem "rake", ">= 0.8.7"
+gem "mocha", ">= 0.9.8"
+
gem "rails", "3.0.pre", :vendored_at => "railties"
-%w(
- activesupport
- activemodel
- actionpack
- actionmailer
- activerecord
- activeresource
-).each do |lib|
+%w(activesupport activemodel actionpack actionmailer activerecord activeresource).each do |lib|
gem lib, '3.0.pre', :vendored_at => lib
end
-gem "rack", "1.0.1"
-gem "rack-mount", :git => "git://github.com/rails/rack-mount.git"
-gem "rack-test", "~> 0.5.0"
-gem "erubis", "~> 2.6.0"
+
+# AR
gem "arel", "0.2.pre", :git => "git://github.com/rails/arel.git"
-gem "mocha"
-gem "sqlite3-ruby"
-gem "RedCloth"
+gem "sqlite3-ruby", ">= 1.2.5"
+
+# AP
+gem "rack", "1.0.1", :git => "git://github.com/rails/rack.git"
+gem "rack-mount", :git => "git://github.com/rails/rack-mount.git"
+gem "rack-test", ">= 0.5.0"
+gem "erubis", ">= 2.6.5"
+gem "RedCloth", ">= 4.2.2"
+
+only :ci do
+ gem "fcgi", ">= 0.8.7"
+ gem "nokogiri", ">= 1.4.0"
+ gem "memcache-client", ">= 1.7.6"
+ gem "pg", ">= 0.8.0"
+end
Please sign in to comment.
Something went wrong with that request. Please try again.