Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

DEPRECATION WARNING in new --edge app #452

Closed
utilum opened this issue Feb 3, 2019 · 6 comments

Comments

@utilum
Copy link

commented Feb 3, 2019

$ ruby -v
ruby 2.6.1p33 (2019-01-30 revision 66950) [x86_64-linux]
$ rails -v
Rails 6.0.0.beta1
$ rails new blog --edge > /dev/null 2>&1
$ cat blog/log/development.log 
DEPRECATION WARNING: Single arity template handlers are deprecated.  Template handlers must
now accept two parameters, the view object and the source for the view object.
Change:
  >> Class#call(template)
To:
  >> Class#call(template, source)
 (called from block (2 levels) in <class:Railtie> at /home/u/.rbenv/versions/2.6.1/lib/ruby/gems/2.6.0/gems/jbuilder-2.8.0/lib/jbuilder/railtie.rb:8)
@kaspth

This comment has been minimized.

Copy link
Member

commented Feb 3, 2019

@jasnow

This comment has been minimized.

Copy link

commented Feb 4, 2019

I'm getting it too.

@tenderlove tenderlove self-assigned this Feb 4, 2019
tenderlove added a commit to rails/rails that referenced this issue Feb 4, 2019
tenderlove added a commit that referenced this issue Feb 4, 2019
This commit brings the JBuilder template handler up to work with Rails 6
and no deprecation warnings.  The `JbuilderHandler.call` method should
work with older Rails versions too.

Fixes #452
@a-ta-ta

This comment has been minimized.

Copy link

commented Jun 4, 2019

Nevertheless I'm on rails 6.0.0.rc1, still getting it
:-\

DEPRECATION WARNING: Single arity template handlers are deprecated. Template handlers must
now accept two parameters, the view object and the source for the view object.
Change:
  >> Coffee::Rails::TemplateHandler.call(template)
To:
  >> Coffee::Rails::TemplateHandler.call(template, source)
 (called from block (2 levels) in require at /home/alex/.rbenv/versions/2.5.1/lib/ruby/gems/2.5.0/gems/bundler-2.0.1/lib/bundler/runtime.rb:81)
@charusat09

This comment has been minimized.

Copy link

commented Jul 9, 2019

@a-ta-ta update your coffee-rails gem version to 5.0.0. It should resolve your problem. ref: https://rubygems.org/gems/coffee-rails/versions/5.0.0

@a-ta-ta

This comment has been minimized.

Copy link

commented Aug 12, 2019

@charusat09 Thanks a lot!

@nezirz

This comment has been minimized.

Copy link

commented Sep 12, 2019

Upgrading the coffee-rails fixed issue in my case on ruby 2.6.4 and rails 6.0.0

alaxalves added a commit to alaxalves/dontfile that referenced this issue Oct 2, 2019
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
7 participants
You can’t perform that action at this time.