Skip to content
Newer
Older
100644 63 lines (40 sloc) 2.36 KB
1051c4a @deleteme Updating README.md to make it more obvious which version of jQuery an…
deleteme authored
1 # jquery-rails
7d6abae @indirect First try. I think it works?
indirect authored
2
2fdd389 @indirect Explain how to require jQueryUI in Rails 3.1
indirect authored
3 jQuery! For Rails! So great.
4
1051c4a @deleteme Updating README.md to make it more obvious which version of jQuery an…
deleteme authored
5 This gem provides:
6
6f7938f @Fudoshiki Update README.md
Fudoshiki authored
7 * jQuery 1 and jQuery 2
c1eb6ae @indirect Add Acknowledgements to the readme
indirect authored
8 * the jQuery UJS adapter
9 * assert_select_jquery to test jQuery responses in Ruby tests
2fdd389 @indirect Explain how to require jQueryUI in Rails 3.1
indirect authored
10
a6d4ceb @JangoSteve Added note on new jquery-rails versioning guidelines
JangoSteve authored
11 ## Versions
12
13 Starting with v2.1, the jquery-rails gem follows these version guidelines
4f70054 @lucasmazza Remove support for Rails 3/Rails 3.1 apps.
lucasmazza authored
14 to provide more control over your app's jQuery version from your Gemfile:
a6d4ceb @JangoSteve Added note on new jquery-rails versioning guidelines
JangoSteve authored
15
16 ```
4f70054 @lucasmazza Remove support for Rails 3/Rails 3.1 apps.
lucasmazza authored
17 patch version bump = updates to jquery-ujs, jquery-rails, and patch-level updates to jQuery
18 minor version bump = minor-level updates to jQuery
19 major version bump = major-level updates to jQuery and updates to Rails which may be backwards-incompatible
a6d4ceb @JangoSteve Added note on new jquery-rails versioning guidelines
JangoSteve authored
20 ```
21
bd6c641 @indirect Version 3.0.3 with changelog
indirect authored
22 See [VERSIONS.md](VERSIONS.md) to see which versions of jquery-rails bundle which
9ebcacd @JangoSteve Added note to README about jquery versions in CHANGELOG.
JangoSteve authored
23 versions of jQuery.
24
b42dccc @JangoSteve Updated readme to make clearer
JangoSteve authored
25 ## Installation
5917d1d @indirect explain how to use both Rails 3.0 and 3.1 in the readme
indirect authored
26
b42dccc @JangoSteve Updated readme to make clearer
JangoSteve authored
27 The jquery and jquery-ujs files will be added to the asset pipeline and available for you to use. If they're not already in `app/assets/javascripts/application.js` by default, add these lines:
3bd7710 @indirect explain installation a bit better
indirect authored
28
b42dccc @JangoSteve Updated readme to make clearer
JangoSteve authored
29 ```js
30 //= require jquery
31 //= require jquery_ujs
32 ```
3bd7710 @indirect explain installation a bit better
indirect authored
33
e1bd378 @lucasmazza Update README
lucasmazza authored
34 If you want to use jQuery 2, you can require `jquery2` instead:
35
36 ```js
37 //= require jquery2
38 //= require jquery_ujs
39 ```
40
2fdcdb2 @JangoSteve Removed jQuery UI from gem.
JangoSteve authored
41 For jQuery UI, we recommend the [jquery-ui-rails](https://github.com/joliss/jquery-ui-rails) gem, as it includes the jquery-ui css and allows easier customization.
5917d1d @indirect explain how to use both Rails 3.0 and 3.1 in the readme
indirect authored
42
2fdcdb2 @JangoSteve Removed jQuery UI from gem.
JangoSteve authored
43 *As of v3.0, jquery-rails no longer includes jQuery UI. Use the
44 jquery-ui-rails gem above.*
5917d1d @indirect explain how to use both Rails 3.0 and 3.1 in the readme
indirect authored
45
33a5fff @maclover7 Add CONTRIBUTING.md [ci skip]
maclover7 authored
46 ## Contributing to jquery-rails
b42dccc @JangoSteve Updated readme to make clearer
JangoSteve authored
47
33a5fff @maclover7 Add CONTRIBUTING.md [ci skip]
maclover7 authored
48 jquery-rails is work of many contributors. You're encouraged to submit pull requests, propose
49 features and discuss issues.
b42dccc @JangoSteve Updated readme to make clearer
JangoSteve authored
50
c1eb6ae @indirect Add Acknowledgements to the readme
indirect authored
51 * If it's an issue pertaining to the jquery-ujs javascript, please report it to the [jquery-ujs project](https://github.com/rails/jquery-ujs).
b42dccc @JangoSteve Updated readme to make clearer
JangoSteve authored
52
4f70054 @lucasmazza Remove support for Rails 3/Rails 3.1 apps.
lucasmazza authored
53 * If the jQuery scripts are outdated (i.e. maybe a new version of jquery was released yesterday), feel free to open an issue and prod us to get that thing updated. However, for security reasons, we won't be accepting pull requests with updated jQuery scripts.
c1eb6ae @indirect Add Acknowledgements to the readme
indirect authored
54
33a5fff @maclover7 Add CONTRIBUTING.md [ci skip]
maclover7 authored
55 See [CONTRIBUTING](CONTRIBUTING.md).
56
57 ## License
58 jquery-rails is released under the [MIT License](MIT-LICENSE).
59
c1eb6ae @indirect Add Acknowledgements to the readme
indirect authored
60 ## Acknowledgements
61
62 Many thanks are due to all of [the jquery-rails contributors](https://github.com/rails/jquery-rails/graphs/contributors). Special thanks to [JangoSteve](http://github.com/JangoSteve) for tirelessly answering questions and accepting patches, and the [Rails Core Team](https://github.com/organizations/rails/teams/617) for making jquery-rails an official part of Rails 3.1.
Something went wrong with that request. Please try again.