Rails 4 updates #24

Merged
merged 1 commit into from Aug 15, 2013

Conversation

Projects
None yet
9 participants
Contributor

bbuchalter commented Jul 15, 2013

Probably don't want to put this in master just yet, but a rails4 branch would be helpful. Not sure I got everything, but it's a start.

@bbuchalter I'm giving your branch a try in a project now.

+1 - This got rid of the deprecation warnings for me.

👍 Rails 4 is out now and those deprecation warnings need to disappear :)

Yeah, this has been working for me.

Contributor

bbuchalter commented Aug 14, 2013

Agreed. It's been in production for me since the time of the pull request.

On Wed, Aug 14, 2013 at 3:02 PM, Cody Robbins notifications@github.comwrote:

Yeah, this has been working for me.


Reply to this email directly or view it on GitHubhttps://github.com/rails/prototype-rails/pull/24#issuecomment-22658901
.

"Who is the happier man, he who has braved the storm of life and lived, or
he who has stayed securely on shore and merely existed?" - HST
"In the long run, you could die tomorrow." - LS

@fxn +1 Using this in production. Can you merge this?

Owner

fxn commented Aug 15, 2013

Thanks for the feedback guys.

@fxn fxn added a commit that referenced this pull request Aug 15, 2013

@fxn fxn Merge pull request #24 from bbuchalter/rails4
Rails 4 updates
42ca92b

@fxn fxn merged commit 42ca92b into rails:master Aug 15, 2013

@jeremy jeremy added a commit that referenced this pull request Aug 16, 2013

@jeremy jeremy Bump gem version to account for #24 34ec5b9
Owner

jeremy commented Aug 16, 2013

Fixed RJS and test suite @ f0ceb99 ಠ_ಠ

How do I use this gem in a Rails 3.2 app now?

@JustinMyers When it's out, lock the gem version in your Gemfile to the last version known to work with rails < 4

FLemon commented Oct 7, 2014

@Intrepidd , any version that is compatible with both Rails3 and 4 ?

@FLemon wow, that's an old comment you just dug up :)

What are the issues with Rails 3.2 ? I can try and make a pull request if it's not too complex

FLemon commented Oct 7, 2014

@Intrepidd , quick reply, thanks a lot!
am trying to upgrade a current app from Rails3.2x to Rails4, in the transition period(before changing Rails 4 in the Gemfile), need to find the version for the gem to be Rails3&4 compatible.

So, really no issues found yet, but trying to understand more about the gem(wether it is either Rails3 or Rails4, no coexist transition version)
currently we are using prototype-rails v3.2.1.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment