Permalink
Commits on Feb 17, 2017
  1. Merge pull request #133 from yahonda/remove_duplicate_updateing_rubygems

    Revert "Update rubygems to the latest one"
    fxn committed on GitHub Feb 17, 2017
  2. Revert "Update rubygems to the latest one"

    This reverts commit c17c630.
    yahonda committed Feb 17, 2017
Commits on Feb 12, 2017
  1. provision latest RubyGems

    fxn committed Feb 12, 2017
  2. set MySQL password in env variable while provisioning

    See the comment in the patch for the rationale.
    
    Closes #132.
    fxn committed Feb 12, 2017
Commits on Jan 31, 2017
  1. Merge pull request #129 from yahonda/ruby24

    Use Ruby 2.4
    fxn committed on GitHub Jan 31, 2017
  2. Update rubygems to the latest one

    yahonda committed Jan 31, 2017
  3. Use Ruby 2.4

    yahonda committed Jan 31, 2017
Commits on Jan 28, 2017
  1. link to the contributing guide for tips

    fxn committed on GitHub Jan 28, 2017
Commits on Dec 21, 2016
  1. Merge pull request #127 from kyledecot/patch-1

    Removes extra ` from README.md
    fxn committed on GitHub Dec 21, 2016
  2. Removes extra ` from README.md

    kyledecot committed on GitHub Dec 21, 2016
Commits on Dec 1, 2016
  1. Indent some code

    fxn committed on GitHub Dec 1, 2016
  2. Merge pull request #125 from oswaldoferreira/master

    Add troubleshooting docs with "vagrant up" known issue
    fxn committed on GitHub Dec 1, 2016
Commits on Nov 3, 2016
  1. configure 2GB of RAM [Philipp Fehre & Xavier Noria]

    The test suite of Active Record reaches ~850MB in a cold run,
    let's add some safety margin.
    fxn committed Nov 3, 2016
  2. upgrade base box to Ubuntu 16.10

    fxn committed Nov 3, 2016
Commits on Jun 19, 2016
  1. prefer single quotes

    fxn committed on GitHub Jun 19, 2016
Commits on May 26, 2016
  1. install Blade dependency [closes #118]

    Thanks to @meinac for the patch.
    fxn committed May 26, 2016
Commits on Mar 2, 2016
  1. let the VM use 1G of RAM and two cores by default

    bundle install and some suites were starting to fail with less memory.
    fxn committed Mar 2, 2016
  2. upgrade the base box to 15.10

    fxn committed Mar 2, 2016
  3. Merge pull request #108 from yahonda/add_swap

    Add swapfile to avoid `Errno::ENOMEM: Cannot allocate memory - fork(2)`
    fxn committed Mar 2, 2016
Commits on Feb 4, 2016
  1. Merge pull request #114 from meinac/minor_fix_readme

    Minor readme fix
    fxn committed Feb 4, 2016
  2. Minor readme fix

    meinac committed Feb 4, 2016
Commits on Jan 10, 2016
  1. install Ruby 2.3

    fxn committed Jan 10, 2016
Commits on Aug 21, 2015
Commits on Jun 16, 2015
  1. updates MOTD

    fxn committed Jun 16, 2015
Commits on May 5, 2015
  1. switch to 64-bit [closes #100]

    fxn committed May 5, 2015
Commits on Jan 24, 2015
  1. Merge pull request #93 from deivid-rodriguez/patch-1

    Match current file structure
    fxn committed Jan 24, 2015
Commits on Jan 14, 2015
  1. edits 4ac4b00

    * No need to say "if you have issues", this has to be done
      if working on master.
    
    * Refer to "the web server" rather than WEBrick.
    
    * Typography.
    fxn committed Jan 14, 2015
  2. Merge pull request #90 from maxArturo/add-port-forwarding-clarification-

    #89
    
    Update README for port-forwarding clarification
    fxn committed Jan 14, 2015
Commits on Jan 13, 2015
  1. Update README for port-forwarding clarification

    Often times it's necessary to run WEBrick or any other web server in
    0.0.0.0, instead of 127.0.0.1 which is loopback. Binding to 0.0.0.0
    ensures that the server is accessible in all interfaces and works as
    expected. Many new collaborators can get stuck in this simple hurdle, and
    there is little to no docs on it available.
    maxArturo committed with maxArturo Dec 23, 2014
Commits on Jan 2, 2015
  1. Merge pull request #92 from Fudoshiki/patch-1

    Update README.md
    rafaelfranca committed Jan 2, 2015
  2. Update README.md

    Fudoshiki committed Jan 2, 2015
  3. Merge pull request #91 from PaBLoX-CL/patch-1

    Update to use ruby 2.2.0
    fxn committed Jan 2, 2015