Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Newer
Older
100644 30 lines (24 sloc) 1.154 kb
4bc2cbc @stefanpenner Load RAILS_VERSION relative to the gemspec file.
stefanpenner authored
1 version = File.read(File.expand_path("../RAILS_VERSION",__FILE__)).strip
f221a6f @brynary Leverage VERSION constants from gemspecs to avoid tedious updates when r...
brynary authored
2
67f5d61 @wycats Add rake gemspec and gemspecs to the repo
wycats authored
3 Gem::Specification.new do |s|
031139b @dhh Homogenize gemspecs and remove the deprecated autorequire
dhh authored
4 s.platform = Gem::Platform::RUBY
5 s.name = 'rails'
deb00bc @brynary Read Rails version from a file instead of modifying the load path and do...
brynary authored
6 s.version = version
56ea206 @jeremy Wordsmith gem descriptions
jeremy authored
7 s.summary = 'Full-stack web application framework.'
8 s.description = 'Ruby on Rails is a full-stack web framework optimized for programmer happiness and sustainable productivity. It encourages beautiful code by favoring convention over configuration.'
d956003 @dhh Neat and tidy, I say
dhh authored
9
10 s.required_ruby_version = '>= 1.8.7'
f30b7a0 @wycats Rails requires Rubygems 1.3.6
wycats authored
11 s.required_rubygems_version = ">= 1.3.6"
031139b @dhh Homogenize gemspecs and remove the deprecated autorequire
dhh authored
12
13 s.author = 'David Heinemeier Hansson'
14 s.email = 'david@loudthinking.com'
15 s.homepage = 'http://www.rubyonrails.org'
16 s.rubyforge_project = 'rails'
ca37865 @indirect Update the Bundler snippet for 0.9.15 and above
indirect authored
17
a64bfc3 @felipero moved rails binary to rails gem, so rubygems can find specific versions ...
felipero authored
18 s.bindir = 'bin'
19 s.executables = ['rails']
20 s.default_executable = 'rails'
67f5d61 @wycats Add rake gemspec and gemspecs to the repo
wycats authored
21
d956003 @dhh Neat and tidy, I say
dhh authored
22 s.add_dependency('activesupport', version)
23 s.add_dependency('actionpack', version)
24 s.add_dependency('activerecord', version)
25 s.add_dependency('activeresource', version)
26 s.add_dependency('actionmailer', version)
27 s.add_dependency('railties', version)
8279c06 @spastorino Relax bundler dependency to allow the faster 1.1
spastorino authored
28 s.add_dependency('bundler', '~> 1.0')
67f5d61 @wycats Add rake gemspec and gemspecs to the repo
wycats authored
29 end
Something went wrong with that request. Please try again.