Skip to content
Newer
Older
100644 102 lines (82 sloc) 2.3 KB
ef8c2a8 @dasch Also use double quotes for #source
dasch authored May 24, 2011
1 source "http://rubygems.org"
9f01dff Get rails tests running on bundler 0.9
Carl Lerche authored Jan 31, 2010
2
4eb0d58 @drogus Use gemspec instead of gem rails in Gemfile
drogus authored Dec 18, 2010
3 gemspec
4
13df581 @tenderlove using AREL from the environment if it exists
tenderlove authored Jul 25, 2010
5 if ENV['AREL']
6 gem "arel", :path => ENV['AREL']
562583c @jonleighton Add ActiveRecord::Relation#uniq for toggling DISTINCT in the SQL query
jonleighton authored Nov 4, 2011
7 else
8 gem "arel", :git => "git://github.com/rails/arel"
13df581 @tenderlove using AREL from the environment if it exists
tenderlove authored Jul 25, 2010
9 end
10
6779064 @guilleiguaran Remove hard dependency on bcrypt.
guilleiguaran authored Sep 1, 2011
11 gem "bcrypt-ruby", "~> 3.0.0"
fe37b48 @mitijain123 Bringing back the jquery-rails. One test is dependent.
mitijain123 authored Jul 24, 2011
12 gem "jquery-rails"
5f0b37c @tenderlove Switching rack-mount to journey.
tenderlove authored Sep 8, 2011
13
14 if ENV['JOURNEY']
15 gem "journey", :path => ENV['JOURNEY']
16 else
17 gem "journey", :git => "git://github.com/rails/journey"
18 end
19
2f6e389 @josevalim Make compressors lazily load.
josevalim authored Jul 6, 2011
20 # This needs to be with require false to avoid
21 # it being automatically loaded by sprockets
5e35d62 @arunagw Uglifier bump
arunagw authored Sep 5, 2011
22 gem "uglifier", ">= 1.0.3", :require => false
2b47059 @josh Add sprockets to Gemfile for testing
josh authored Mar 29, 2011
23
c930170 @arunagw No need to check ruby version here
arunagw authored Oct 22, 2011
24 gem "rake", ">= 0.8.7"
a584b4c @jeremy Get rack from rails/rack.git. Introduce ci-only deps.
jeremy authored Nov 10, 2009
25 gem "mocha", ">= 0.9.8"
5bc98c9 @fxn defines a :doc group in the project's Rakefile, just for the sake of …
fxn authored Jan 12, 2011
26
27 group :doc do
28 gem "rdoc", "~> 3.4"
827a0fe @fxn use sdoc to generate the API
fxn authored Aug 27, 2011
29 gem "sdoc", "~> 0.3"
b45a90f @tenderlove redcloth does not install on 1.9.3
tenderlove authored Feb 8, 2011
30 gem "RedCloth", "~> 4.2" if RUBY_VERSION < "1.9.3"
8b25b55 @vijaydev add w3c_validators gem to the doc group to fix failing validation of …
vijaydev authored Jul 4, 2011
31 gem "w3c_validators"
5bc98c9 @fxn defines a :doc group in the project's Rakefile, just for the sake of …
fxn authored Jan 12, 2011
32 end
a584b4c @jeremy Get rack from rails/rack.git. Introduce ci-only deps.
jeremy authored Nov 10, 2009
33
2c4fcec @spastorino Gemfile now makes use of platforms calls with blocks instead of elsif…
spastorino authored Jul 26, 2010
34 # AS
35 gem "memcache-client", ">= 1.8.5"
36
37 platforms :mri_18 do
61001e7 @spastorino group :mri deleted in favor of RUBY_ENGINE and RUBY_VERSION usage.
spastorino authored May 19, 2010
38 gem "system_timer"
d664eba @joshk Added a .travis.yml config and travis specific ci script.
joshk authored Jul 15, 2011
39 gem "ruby-debug", ">= 0.10.3" unless ENV['TRAVIS']
2fe70c1 @josevalim Booya, sprockets now works from Engines.
josevalim authored Apr 15, 2011
40 gem "json"
61001e7 @spastorino group :mri deleted in favor of RUBY_ENGINE and RUBY_VERSION usage.
spastorino authored May 19, 2010
41 end
42
29b54a4 @spastorino Bring back ruby-debug19 for Ruby versions < 1.9.3
spastorino authored Nov 5, 2010
43 platforms :mri_19 do
44 # TODO: Remove the conditional when ruby-debug19 supports Ruby >= 1.9.3
d664eba @joshk Added a .travis.yml config and travis specific ci script.
joshk authored Jul 15, 2011
45 gem "ruby-debug19", :require => "ruby-debug" unless RUBY_VERSION > "1.9.2" || ENV['TRAVIS']
29b54a4 @spastorino Bring back ruby-debug19 for Ruby versions < 1.9.3
spastorino authored Nov 5, 2010
46 end
47
74eb848 @zhengjia remove ruby-prof for rubinius in Gemfile
zhengjia authored Jul 22, 2011
48 platforms :mri do
49 group :test do
50 gem "ruby-prof" if RUBY_VERSION < "1.9.3"
51 end
52 end
53
2c4fcec @spastorino Gemfile now makes use of platforms calls with blocks instead of elsif…
spastorino authored Jul 25, 2010
54 platforms :ruby do
e06c448 @drogus Install rb-fsevent gem if ENV[RB_FSEVENT] is set
drogus authored Mar 22, 2011
55 if ENV["RB_FSEVENT"]
962936c @dasch Use quotes consistently in Gemfile
dasch authored May 24, 2011
56 gem "rb-fsevent"
e06c448 @drogus Install rb-fsevent gem if ENV[RB_FSEVENT] is set
drogus authored Mar 22, 2011
57 end
962936c @dasch Use quotes consistently in Gemfile
dasch authored May 24, 2011
58 gem "json"
59 gem "yajl-ruby"
171491b @gazay Change version of nokogiri gem
gazay authored Jun 17, 2011
60 gem "nokogiri", ">= 1.4.5"
976a9d9 @arunagw Grouped the ruby-prof into test.
arunagw authored May 5, 2011
61
2c4fcec @spastorino Gemfile now makes use of platforms calls with blocks instead of elsif…
spastorino authored Jul 25, 2010
62 # AR
1de89e5 @hone AR wants sqlite3 1.3.4
hone authored Sep 22, 2011
63 gem "sqlite3", "~> 1.3.4"
c0db784 @nicksieger More accurate JRuby gem requirements
nicksieger authored May 19, 2010
64
65 group :db do
d664eba @joshk Added a .travis.yml config and travis specific ci script.
joshk authored Jul 15, 2011
66 gem "pg", ">= 0.11.0" unless ENV['TRAVIS'] # once pg is on travis this can be removed
c0db784 @nicksieger More accurate JRuby gem requirements
nicksieger authored May 19, 2010
67 gem "mysql", ">= 2.8.1"
301cad4 @guilleiguaran Bump to mysql2 0.3.6
guilleiguaran authored Jun 17, 2011
68 gem "mysql2", ">= 0.3.6"
c0db784 @nicksieger More accurate JRuby gem requirements
nicksieger authored May 19, 2010
69 end
2c4fcec @spastorino Gemfile now makes use of platforms calls with blocks instead of elsif…
spastorino authored Jul 25, 2010
70 end
71
72 platforms :jruby do
73 gem "ruby-debug", ">= 0.10.3"
d1f10e7 @arunagw Test failing with Jruby "uninitialized constant TestJSONEncoding::JSON"
arunagw authored Apr 16, 2011
74 gem "json"
b2bf725 @arunagw Bump AR-JDBC version.
arunagw authored Sep 17, 2011
75 gem "activerecord-jdbcsqlite3-adapter", ">= 1.2.0"
7789663 Put MySQL and Postgres in an :only block so you can gem bundle --only…
Yehuda Katz authored Dec 31, 2009
76
ad13eb7 @spastorino Add a TODO to remove gem "jruby-openssl" when jruby-openssl is merge …
spastorino authored Oct 7, 2010
77 # This is needed by now to let tests work on JRuby
78 # TODO: When the JRuby guys merge jruby-openssl in
79 # jruby this will be removed
ea30da3 @anildigital Add jruby-openssl gem in Gemfile necessary for JRuby
anildigital authored Oct 6, 2010
80 gem "jruby-openssl"
81
c0db784 @nicksieger More accurate JRuby gem requirements
nicksieger authored May 19, 2010
82 group :db do
b2bf725 @arunagw Bump AR-JDBC version.
arunagw authored Sep 17, 2011
83 gem "activerecord-jdbcmysql-adapter", ">= 1.2.0"
84 gem "activerecord-jdbcpostgresql-adapter", ">= 1.2.0"
c0db784 @nicksieger More accurate JRuby gem requirements
nicksieger authored May 19, 2010
85 end
7789663 Put MySQL and Postgres in an :only block so you can gem bundle --only…
Yehuda Katz authored Jan 1, 2010
86 end
4e3d220 @rsim added dependencies in Gemfile for running ActiveRecord tests with Ora…
rsim authored Aug 17, 2010
87
88 # gems that are necessary for ActiveRecord tests with Oracle database
89 if ENV['ORACLE_ENHANCED_PATH'] || ENV['ORACLE_ENHANCED']
90 platforms :ruby do
962936c @dasch Use quotes consistently in Gemfile
dasch authored May 24, 2011
91 gem "ruby-oci8", ">= 2.0.4"
4e3d220 @rsim added dependencies in Gemfile for running ActiveRecord tests with Ora…
rsim authored Aug 16, 2010
92 end
93 if ENV['ORACLE_ENHANCED_PATH']
962936c @dasch Use quotes consistently in Gemfile
dasch authored May 24, 2011
94 gem "activerecord-oracle_enhanced-adapter", :path => ENV['ORACLE_ENHANCED_PATH']
4e3d220 @rsim added dependencies in Gemfile for running ActiveRecord tests with Ora…
rsim authored Aug 16, 2010
95 else
96 gem "activerecord-oracle_enhanced-adapter", :git => "git://github.com/rsim/oracle-enhanced.git"
97 end
98 end
b564ffc @yahonda To support ActiveRecord unit tests for IBM DB2
yahonda authored Oct 2, 2011
99
8cc70cf @yahonda Fix typo in Rakefile
yahonda authored Oct 3, 2011
100 # A gem necessary for ActiveRecord tests with IBM DB
b564ffc @yahonda To support ActiveRecord unit tests for IBM DB2
yahonda authored Oct 3, 2011
101 gem "ibm_db" if ENV['IBM_DB']
Something went wrong with that request. Please try again.