Skip to content
Newer
Older
100644 14 lines (9 sloc) 273 Bytes
4fa615a @josevalim Update ruby_version_check.
josevalim authored Dec 20, 2011
1 if RUBY_VERSION < '1.9.3'
be43ad6 @jeremy Support ruby 1.8.7 and 1.9.2 (and development versions)
jeremy authored Jun 11, 2010
2 desc = defined?(RUBY_DESCRIPTION) ? RUBY_DESCRIPTION : "ruby #{RUBY_VERSION} (#{RUBY_RELEASE_DATE})"
48e7edc @seckar Reject Ruby 1.8.3 when loading Rails; extract version checking code.
seckar authored Mar 19, 2006
3 abort <<-end_message
4
4fa615a @josevalim Update ruby_version_check.
josevalim authored Dec 20, 2011
5 Rails 4 requires Ruby 1.9.3+.
1a56548 @jeremy Single ruby version requirement message
jeremy authored Jun 11, 2010
6
be43ad6 @jeremy Support ruby 1.8.7 and 1.9.2 (and development versions)
jeremy authored Jun 11, 2010
7 You're running
8 #{desc}
9
10 Please upgrade to continue.
11
12 end_message
48e7edc @seckar Reject Ruby 1.8.3 when loading Rails; extract version checking code.
seckar authored Mar 19, 2006
13 end
Something went wrong with that request. Please try again.