Skip to content
Newer
Older
100644 27 lines (21 sloc) 1.03 KB
f221a6f @brynary Leverage VERSION constants from gemspecs to avoid tedious updates whe…
brynary authored Mar 1, 2010
1 $:.unshift "lib"
2 require "active_support/version"
3
67f5d61 @wycats Add rake gemspec and gemspecs to the repo
wycats authored Aug 31, 2009
4 Gem::Specification.new do |s|
031139b @dhh Homogenize gemspecs and remove the deprecated autorequire
dhh authored Feb 3, 2010
5 s.platform = Gem::Platform::RUBY
6 s.name = 'activesupport'
f221a6f @brynary Leverage VERSION constants from gemspecs to avoid tedious updates whe…
brynary authored Mar 2, 2010
7 s.version = ActiveSupport::VERSION::STRING
56ea206 @jeremy Wordsmith gem descriptions
jeremy authored Mar 2, 2010
8 s.summary = 'A toolkit of support libraries and Ruby core extensions extracted from the Rails framework.'
9 s.summary = 'A toolkit of support libraries and Ruby core extensions extracted from the Rails framework. Rich support for multibyte strings, internationalization, time zones, and testing.'
5fe3dc4 @mikel Adding ruby version spec to all gemspec files to at least 1.8.7
mikel authored Feb 8, 2010
10 s.required_ruby_version = '>= 1.8.7'
67f5d61 @wycats Add rake gemspec and gemspecs to the repo
wycats authored Sep 1, 2009
11
031139b @dhh Homogenize gemspecs and remove the deprecated autorequire
dhh authored Feb 4, 2010
12 s.author = 'David Heinemeier Hansson'
13 s.email = 'david@loudthinking.com'
14 s.homepage = 'http://www.rubyonrails.org'
15 s.rubyforge_project = 'activesupport'
f095e6f Fixes some problems with getting a new app working
Yehuda Katz authored Dec 27, 2009
16
031139b @dhh Homogenize gemspecs and remove the deprecated autorequire
dhh authored Feb 4, 2010
17 s.files = Dir['CHANGELOG', 'README', 'lib/**/*']
897b9ac @josh Make activesupport.gemspec the authoritative source instead of genera…
josh authored Sep 25, 2009
18 s.require_path = 'lib'
031139b @dhh Homogenize gemspecs and remove the deprecated autorequire
dhh authored Feb 4, 2010
19
897b9ac @josh Make activesupport.gemspec the authoritative source instead of genera…
josh authored Sep 25, 2009
20 s.has_rdoc = true
67f5d61 @wycats Add rake gemspec and gemspecs to the repo
wycats authored Sep 1, 2009
21
66d5378 @jeremy Bump i18n for new public I18n.normalize_keys
jeremy authored Feb 25, 2010
22 s.add_dependency('i18n', '~> 0.3.4')
031139b @dhh Homogenize gemspecs and remove the deprecated autorequire
dhh authored Feb 4, 2010
23 s.add_dependency('tzinfo', '~> 0.3.16')
24 s.add_dependency('builder', '~> 2.1.2')
25 s.add_dependency('memcache-client', '~> 1.7.5')
67f5d61 @wycats Add rake gemspec and gemspecs to the repo
wycats authored Sep 1, 2009
26 end
Something went wrong with that request. Please try again.