Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Newer
Older
100644 24 lines (17 sloc) 0.94 kb
4bc2cbc Stefan Penner Load RAILS_VERSION relative to the gemspec file.
stefanpenner authored
1 version = File.read(File.expand_path("../../RAILS_VERSION", __FILE__)).strip
f221a6f Bryan Helmkamp Leverage VERSION constants from gemspecs to avoid tedious updates when r...
brynary authored
2
67f5d61 Yehuda Katz Add rake gemspec and gemspecs to the repo
wycats authored
3 Gem::Specification.new do |s|
031139b David Heinemeier Hansson Homogenize gemspecs and remove the deprecated autorequire
dhh authored
4 s.platform = Gem::Platform::RUBY
5 s.name = 'activesupport'
deb00bc Bryan Helmkamp Read Rails version from a file instead of modifying the load path and do...
brynary authored
6 s.version = version
56ea206 Jeremy Kemper Wordsmith gem descriptions
jeremy authored
7 s.summary = 'A toolkit of support libraries and Ruby core extensions extracted from the Rails framework.'
5c40c26 Jeremy Kemper Stray line. Typo.
jeremy authored
8 s.description = 'A toolkit of support libraries and Ruby core extensions extracted from the Rails framework. Rich support for multibyte strings, internationalization, time zones, and testing.'
d956003 David Heinemeier Hansson Neat and tidy, I say
dhh authored
9
5fe3dc4 Mikel Lindsaar Adding ruby version spec to all gemspec files to at least 1.8.7
mikel authored
10 s.required_ruby_version = '>= 1.8.7'
67f5d61 Yehuda Katz Add rake gemspec and gemspecs to the repo
wycats authored
11
d5646e8 José Valim Move I18n dependency back to ActiveSupport.
josevalim authored
12 s.author = 'David Heinemeier Hansson'
13 s.email = 'david@loudthinking.com'
14 s.homepage = 'http://www.rubyonrails.org'
f095e6f Fixes some problems with getting a new app working
Yehuda Katz authored
15
1679aa5 Franck Verrot Synchronize the gemspecs since CHANGELOG has been renamed to CHANGELOG.m...
franckverrot authored
16 s.files = Dir['CHANGELOG.md', 'MIT-LICENSE', 'README.rdoc', 'lib/**/*']
897b9ac Joshua Peek Make activesupport.gemspec the authoritative source instead of generatin...
josh authored
17 s.require_path = 'lib'
b246218 Josh Kalderimis remove MultiJson from the Gemfile and instead add the current rc to the ...
joshk authored
18
9e94e26 Santiago Pastorino Merge pull request #4412 from kennyj/fix_3743
spastorino authored
19 s.rdoc_options.concat ['--encoding', 'UTF-8']
20
62d9c83 José Valim Depend on I18n ~> 0.6
josevalim authored
21 s.add_dependency('i18n', '~> 0.6')
e01bf0a Erik Michaels-Ober Revert "multi_json is restricted to < 1.3 "
sferik authored
22 s.add_dependency('multi_json', '~> 1.0')
67f5d61 Yehuda Katz Add rake gemspec and gemspecs to the repo
wycats authored
23 end
Something went wrong with that request. Please try again.