Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Newer
Older
100644 43 lines (33 sloc) 0.902 kb
a584b4c Jeremy Kemper Get rack from rails/rack.git. Introduce ci-only deps.
jeremy authored
1 gem "rake", ">= 0.8.7"
2 gem "mocha", ">= 0.9.8"
1ebfd99 Pratik Add ruby-debug to Gemfile for Ruby < 1.9
lifo authored
3 gem "ruby-debug", ">= 0.10.3" if RUBY_VERSION < '1.9'
a584b4c Jeremy Kemper Get rack from rails/rack.git. Introduce ci-only deps.
jeremy authored
4
2bfa477 David Heinemeier Hansson Fix deprecated :vendored_at option
dhh authored
5 gem "rails", "3.0.pre", :path => "railties"
a584b4c Jeremy Kemper Get rack from rails/rack.git. Introduce ci-only deps.
jeremy authored
6 %w(activesupport activemodel actionpack actionmailer activerecord activeresource).each do |lib|
2bfa477 David Heinemeier Hansson Fix deprecated :vendored_at option
dhh authored
7 gem lib, '3.0.pre', :path => lib
4f6d6f7 Have all the tests running off a single Gemfile
Yehuda Katz + Carl Lerche authored
8 end
a584b4c Jeremy Kemper Get rack from rails/rack.git. Introduce ci-only deps.
jeremy authored
9
135d32c José Valim Move i18n to Gemfile.
josevalim authored
10 # AS
11 gem "i18n", ">= 0.3.0"
12
a584b4c Jeremy Kemper Get rack from rails/rack.git. Introduce ci-only deps.
jeremy authored
13 # AR
3bdfda0 Jeremy Kemper Bump arel dep to 0.2.pre
jeremy authored
14 gem "arel", "0.2.pre", :git => "git://github.com/rails/arel.git"
a584b4c Jeremy Kemper Get rack from rails/rack.git. Introduce ci-only deps.
jeremy authored
15 gem "sqlite3-ruby", ">= 1.2.5"
7789663 Put MySQL and Postgres in an :only block so you can gem bundle --only de...
Yehuda Katz authored
16
17 only :test do
18 gem "pg", ">= 0.8.0"
19 gem "mysql", ">= 2.8.1"
20 end
a584b4c Jeremy Kemper Get rack from rails/rack.git. Introduce ci-only deps.
jeremy authored
21
22 # AP
17b6053 Joshua Peek Float on rack/master in preparation for rack 1.1 gem release
josh authored
23 gem "rack", "1.1.0", :git => "git://github.com/rack/rack.git"
ec09545 David Heinemeier Hansson Dont auto require rubygems, move dep on rack-test to Gemfile
dhh authored
24 gem "rack-test", "0.5.3"
a584b4c Jeremy Kemper Get rack from rails/rack.git. Introduce ci-only deps.
jeremy authored
25 gem "RedCloth", ">= 4.2.2"
26
aef7e21 Jeremy Kemper Use an env var to expand the CI bundle. Using bundler's 'only' includes ...
jeremy authored
27 if ENV['CI']
60558cc Jeremy Kemper CI: no system gems required
jeremy authored
28 disable_system_gems
29
a584b4c Jeremy Kemper Get rack from rails/rack.git. Introduce ci-only deps.
jeremy authored
30 gem "nokogiri", ">= 1.4.0"
31 gem "memcache-client", ">= 1.7.6"
f14eb68 Jeremy Kemper CI: bundle test-unit on 1.9
jeremy authored
32
33 # fcgi gem doesn't compile on 1.9
34 # avoid minitest strangeness on 1.9
35 if RUBY_VERSION < '1.9.0'
36 gem "fcgi", ">= 0.8.7"
37 else
38 gem "test-unit", ">= 2.0.5"
39 end
a584b4c Jeremy Kemper Get rack from rails/rack.git. Introduce ci-only deps.
jeremy authored
40 end
38aeb15 Moving out some framework specific initializers into the framework libra...
Carlhuda authored
41
135d32c José Valim Move i18n to Gemfile.
josevalim authored
42 disable_system_gems
Something went wrong with that request. Please try again.