Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Newer
Older
100644 88 lines (71 sloc) 2.016 kb
ba57575 Remove references to ActionDispatch::Routing::Routes in favor of Rails.a...
Carl Lerche authored
1 source 'http://rubygems.org'
9f01dff Get rails tests running on bundler 0.9
Carl Lerche authored
2
4eb0d58 @drogus Use gemspec instead of gem rails in Gemfile
drogus authored
3 gemspec
4
13df581 @tenderlove using AREL from the environment if it exists
tenderlove authored
5 if ENV['AREL']
6 gem "arel", :path => ENV['AREL']
7 else
8 gem "arel", :git => "git://github.com/rails/arel.git"
9 end
10
50215f9 @josevalim Rely on Rack::Session stores API for more compatibility across the Ruby ...
josevalim authored
11 gem "rack", :git => "git://github.com/rack/rack.git"
7bf7ab5 @tenderlove use rack-test from git
tenderlove authored
12 gem "rack-test", :git => "git://github.com/brynary/rack-test.git"
9f01dff Get rails tests running on bundler 0.9
Carl Lerche authored
13
ac9443e @josh Switch to sprockets/master
josh authored
14 gem "sprockets", :git => "git://github.com/sstephenson/sprockets.git"
2fe70c1 @josevalim Booya, sprockets now works from Engines.
josevalim authored
15 gem "coffee-script"
3a68aec @josevalim Make generators more modular, add hooks and improve test suite.
josevalim authored
16 gem "sass", ">= 3.0"
2b47059 @josh Add sprockets to Gemfile for testing
josh authored
17
9f01dff Get rails tests running on bundler 0.9
Carl Lerche authored
18 gem "rake", ">= 0.8.7"
a584b4c @jeremy Get rack from rails/rack.git. Introduce ci-only deps.
jeremy authored
19 gem "mocha", ">= 0.9.8"
5bc98c9 @fxn defines a :doc group in the project's Rakefile, just for the sake of cla...
fxn authored
20
21 group :doc do
22 gem "rdoc", "~> 3.4"
23 gem "horo", "= 1.0.3"
b45a90f @tenderlove redcloth does not install on 1.9.3
tenderlove authored
24 gem "RedCloth", "~> 4.2" if RUBY_VERSION < "1.9.3"
5bc98c9 @fxn defines a :doc group in the project's Rakefile, just for the sake of cla...
fxn authored
25 end
a584b4c @jeremy Get rack from rails/rack.git. Introduce ci-only deps.
jeremy authored
26
2c4fcec @spastorino Gemfile now makes use of platforms calls with blocks instead of elsif lo...
spastorino authored
27 # AS
28 gem "memcache-client", ">= 1.8.5"
89e6b19 @wycats Add tests for an FSSM backend for the file system watcher using the FSSM...
wycats authored
29 gem "fssm", "~> 0.2.5"
2c4fcec @spastorino Gemfile now makes use of platforms calls with blocks instead of elsif lo...
spastorino authored
30
31 platforms :mri_18 do
61001e7 @spastorino group :mri deleted in favor of RUBY_ENGINE and RUBY_VERSION usage.
spastorino authored
32 gem "system_timer"
33 gem "ruby-debug", ">= 0.10.3"
cc81b04 @jeremy AR perf test: switch to mysql2, bundle faker and rbench
jeremy authored
34 gem 'ruby-prof'
2fe70c1 @josevalim Booya, sprockets now works from Engines.
josevalim authored
35 gem "json"
61001e7 @spastorino group :mri deleted in favor of RUBY_ENGINE and RUBY_VERSION usage.
spastorino authored
36 end
37
29b54a4 @spastorino Bring back ruby-debug19 for Ruby versions < 1.9.3
spastorino authored
38 platforms :mri_19 do
39 # TODO: Remove the conditional when ruby-debug19 supports Ruby >= 1.9.3
0e9c7a2 @spastorino Make gem "ruby-debug19" require ruby-debug
spastorino authored
40 gem "ruby-debug19", :require => 'ruby-debug' if RUBY_VERSION < "1.9.3"
29b54a4 @spastorino Bring back ruby-debug19 for Ruby versions < 1.9.3
spastorino authored
41 end
42
2c4fcec @spastorino Gemfile now makes use of platforms calls with blocks instead of elsif lo...
spastorino authored
43 platforms :ruby do
e06c448 @drogus Install rb-fsevent gem if ENV[RB_FSEVENT] is set
drogus authored
44 if ENV["RB_FSEVENT"]
45 gem 'rb-fsevent'
46 end
2218493 @jeremy Bundle json and yajl-ruby gems for AS::JSON testing
jeremy authored
47 gem 'json'
48 gem 'yajl-ruby'
254b0a4 @tenderlove using a merge with a Hash[] rather than a loop to add SAX parsed attribu...
tenderlove authored
49 gem "nokogiri", ">= 1.4.4"
5714438 @spastorino Unforce memcache from AS
spastorino authored
50
2c4fcec @spastorino Gemfile now makes use of platforms calls with blocks instead of elsif lo...
spastorino authored
51 # AR
421e06f @tenderlove updating gem dependency for sqlite3
tenderlove authored
52 gem "sqlite3", "~> 1.3.3"
c0db784 @nicksieger More accurate JRuby gem requirements
nicksieger authored
53
54 group :db do
e50bf67 @josevalim Bring pg back.
josevalim authored
55 gem "pg", ">= 0.9.0"
c0db784 @nicksieger More accurate JRuby gem requirements
nicksieger authored
56 gem "mysql", ">= 2.8.1"
95b9d71 @tenderlove using mysql2 from git
tenderlove authored
57 gem "mysql2", :git => "git://github.com/brianmario/mysql2.git"
c0db784 @nicksieger More accurate JRuby gem requirements
nicksieger authored
58 end
2c4fcec @spastorino Gemfile now makes use of platforms calls with blocks instead of elsif lo...
spastorino authored
59 end
60
61 platforms :jruby do
62 gem "ruby-debug", ">= 0.10.3"
d1f10e7 @arunagw Test failing with Jruby "uninitialized constant TestJSONEncoding::JSON"
arunagw authored
63 gem "json"
c0db784 @nicksieger More accurate JRuby gem requirements
nicksieger authored
64 gem "activerecord-jdbcsqlite3-adapter"
7789663 Put MySQL and Postgres in an :only block so you can gem bundle --only de...
Yehuda Katz authored
65
ad13eb7 @spastorino Add a TODO to remove gem "jruby-openssl" when jruby-openssl is merge in ...
spastorino authored
66 # This is needed by now to let tests work on JRuby
67 # TODO: When the JRuby guys merge jruby-openssl in
68 # jruby this will be removed
ea30da3 @anildigital Add jruby-openssl gem in Gemfile necessary for JRuby
anildigital authored
69 gem "jruby-openssl"
70
c0db784 @nicksieger More accurate JRuby gem requirements
nicksieger authored
71 group :db do
72 gem "activerecord-jdbcmysql-adapter"
73 gem "activerecord-jdbcpostgresql-adapter"
74 end
7789663 Put MySQL and Postgres in an :only block so you can gem bundle --only de...
Yehuda Katz authored
75 end
4e3d220 @rsim added dependencies in Gemfile for running ActiveRecord tests with Oracle...
rsim authored
76
77 # gems that are necessary for ActiveRecord tests with Oracle database
78 if ENV['ORACLE_ENHANCED_PATH'] || ENV['ORACLE_ENHANCED']
79 platforms :ruby do
80 gem 'ruby-oci8', ">= 2.0.4"
81 end
82 if ENV['ORACLE_ENHANCED_PATH']
83 gem 'activerecord-oracle_enhanced-adapter', :path => ENV['ORACLE_ENHANCED_PATH']
84 else
85 gem "activerecord-oracle_enhanced-adapter", :git => "git://github.com/rsim/oracle-enhanced.git"
86 end
87 end
Something went wrong with that request. Please try again.