Skip to content
Newer
Older
100644 30 lines (23 sloc) 1.05 KB
4bc2cbc @stefanpenner Load RAILS_VERSION relative to the gemspec file.
stefanpenner authored
1 version = File.read(File.expand_path("../../RAILS_VERSION", __FILE__)).strip
f221a6f @brynary Leverage VERSION constants from gemspecs to avoid tedious updates whe…
brynary authored
2
67f5d61 @wycats Add rake gemspec and gemspecs to the repo
wycats authored
3 Gem::Specification.new do |s|
031139b @dhh Homogenize gemspecs and remove the deprecated autorequire
dhh authored
4 s.platform = Gem::Platform::RUBY
5 s.name = 'railties'
deb00bc @brynary Read Rails version from a file instead of modifying the load path and…
brynary authored
6 s.version = version
56ea206 @jeremy Wordsmith gem descriptions
jeremy authored
7 s.summary = 'Tools for creating, working with, and running Rails applications.'
8 s.description = 'Rails internals: application bootup, plugins, generators, and rake tasks.'
e883c06 @rahul100885 Updated gemspec for ruby 1.9.3
rahul100885 authored
9 s.required_ruby_version = '>= 1.9.3'
6c7b250 @betamatt Add license field to gemspecs, by Matt Griffin
betamatt authored
10 s.license = 'MIT'
67f5d61 @wycats Add rake gemspec and gemspecs to the repo
wycats authored
11
031139b @dhh Homogenize gemspecs and remove the deprecated autorequire
dhh authored
12 s.author = 'David Heinemeier Hansson'
13 s.email = 'david@loudthinking.com'
14 s.homepage = 'http://www.rubyonrails.org'
15
6d87cd0 @fxn moves the guides up to the root directory
fxn authored
16 s.files = Dir['CHANGELOG.md', 'README.rdoc', 'bin/**/*', 'lib/**/{*,.[a-z]*}']
031139b @dhh Homogenize gemspecs and remove the deprecated autorequire
dhh authored
17 s.require_path = 'lib'
f430d6b @josh Make gemspecs the authoritative source instead of generating them fro…
josh authored
18
71d7c52 @josevalim Update railties.gemspec
josevalim authored
19 s.bindir = 'bin'
20 s.executables = ['rails']
21
f430d6b @josh Make gemspecs the authoritative source instead of generating them fro…
josh authored
22 s.rdoc_options << '--exclude' << '.'
23
f62aba7 @dhh Now that we are compatible with Rake 0.9.0, lets allow it back in
dhh authored
24 s.add_dependency('rake', '>= 0.8.7')
e9e6f63 @josevalim Depend on thor 0.15.4
josevalim authored
25 s.add_dependency('thor', '>= 0.15.4', '< 2.0')
35ae29f @chopmo Fix issue #1598 by adding a dependency to the RDoc gem.
chopmo authored
26 s.add_dependency('rdoc', '~> 3.4')
deb00bc @brynary Read Rails version from a file instead of modifying the load path and…
brynary authored
27 s.add_dependency('activesupport', version)
28 s.add_dependency('actionpack', version)
67f5d61 @wycats Add rake gemspec and gemspecs to the repo
wycats authored
29 end
Something went wrong with that request. Please try again.