Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Newer
Older
100644 36 lines (29 sloc) 0.884 kb
8ed82df @jeremy Force gemcutter source to ensure a consistent arel version
jeremy authored
1 clear_sources
2 source 'http://gemcutter.org'
4f6d6f7 Have all the tests running off a single Gemfile
Yehuda Katz + Carl Lerche authored
3
a584b4c @jeremy Get rack from rails/rack.git. Introduce ci-only deps.
jeremy authored
4 gem "rake", ">= 0.8.7"
5 gem "mocha", ">= 0.9.8"
6
0f1da1c Revert "Bundle I18n 0.2.0."
Yehuda Katz authored
7 gem "rails", "3.0.pre", :vendored_at => "railties"
a584b4c @jeremy Get rack from rails/rack.git. Introduce ci-only deps.
jeremy authored
8 %w(activesupport activemodel actionpack actionmailer activerecord activeresource).each do |lib|
0f1da1c Revert "Bundle I18n 0.2.0."
Yehuda Katz authored
9 gem lib, '3.0.pre', :vendored_at => lib
4f6d6f7 Have all the tests running off a single Gemfile
Yehuda Katz + Carl Lerche authored
10 end
a584b4c @jeremy Get rack from rails/rack.git. Introduce ci-only deps.
jeremy authored
11
12 # AR
3bdfda0 @jeremy Bump arel dep to 0.2.pre
jeremy authored
13 gem "arel", "0.2.pre", :git => "git://github.com/rails/arel.git"
a584b4c @jeremy Get rack from rails/rack.git. Introduce ci-only deps.
jeremy authored
14 gem "sqlite3-ruby", ">= 1.2.5"
15
16 # AP
17 gem "rack", "1.0.1", :git => "git://github.com/rails/rack.git"
18 gem "rack-mount", :git => "git://github.com/rails/rack-mount.git"
19 gem "rack-test", ">= 0.5.0"
20 gem "erubis", ">= 2.6.5"
21 gem "RedCloth", ">= 4.2.2"
22
aef7e21 @jeremy Use an env var to expand the CI bundle. Using bundler's 'only' includes ...
jeremy authored
23 if ENV['CI']
a584b4c @jeremy Get rack from rails/rack.git. Introduce ci-only deps.
jeremy authored
24 gem "nokogiri", ">= 1.4.0"
25 gem "memcache-client", ">= 1.7.6"
26 gem "pg", ">= 0.8.0"
f14eb68 @jeremy CI: bundle test-unit on 1.9
jeremy authored
27
28 # fcgi gem doesn't compile on 1.9
29 # avoid minitest strangeness on 1.9
30 if RUBY_VERSION < '1.9.0'
31 gem "fcgi", ">= 0.8.7"
32 else
33 gem "test-unit", ">= 2.0.5"
34 end
a584b4c @jeremy Get rack from rails/rack.git. Introduce ci-only deps.
jeremy authored
35 end
Something went wrong with that request. Please try again.