Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Newer
Older
100644 27 lines (21 sloc) 0.925 kb
f221a6f @brynary Leverage VERSION constants from gemspecs to avoid tedious updates whe…
brynary authored
1 $:.unshift "lib"
2 require "action_mailer/version"
3
67f5d61 @wycats Add rake gemspec and gemspecs to the repo
wycats authored
4 Gem::Specification.new do |s|
031139b @dhh Homogenize gemspecs and remove the deprecated autorequire
dhh authored
5 s.platform = Gem::Platform::RUBY
6 s.name = 'actionmailer'
f221a6f @brynary Leverage VERSION constants from gemspecs to avoid tedious updates whe…
brynary authored
7 s.version = ActionMailer::VERSION::STRING
031139b @dhh Homogenize gemspecs and remove the deprecated autorequire
dhh authored
8 s.summary = 'Email composition, delivery, and recieval framework (part of Rails).'
9 s.description = 'Email composition, delivery, and recieval framework (part of Rails).'
5fe3dc4 @mikel Adding ruby version spec to all gemspec files to at least 1.8.7
mikel authored
10 s.required_ruby_version = '>= 1.8.7'
f430d6b @josh Make gemspecs the authoritative source instead of generating them fro…
josh authored
11
031139b @dhh Homogenize gemspecs and remove the deprecated autorequire
dhh authored
12 s.author = 'David Heinemeier Hansson'
13 s.email = 'david@loudthinking.com'
14 s.homepage = 'http://www.rubyonrails.org'
15 s.rubyforge_project = 'actionmailer'
67f5d61 @wycats Add rake gemspec and gemspecs to the repo
wycats authored
16
031139b @dhh Homogenize gemspecs and remove the deprecated autorequire
dhh authored
17 s.files = Dir['CHANGELOG', 'README', 'MIT-LICENSE', 'lib/**/*']
18 s.require_path = 'lib'
19 s.requirements << 'none'
67f5d61 @wycats Add rake gemspec and gemspecs to the repo
wycats authored
20
f430d6b @josh Make gemspecs the authoritative source instead of generating them fro…
josh authored
21 s.has_rdoc = true
031139b @dhh Homogenize gemspecs and remove the deprecated autorequire
dhh authored
22
f221a6f @brynary Leverage VERSION constants from gemspecs to avoid tedious updates whe…
brynary authored
23 s.add_dependency('actionpack', "= #{ActionMailer::VERSION::STRING}")
cefc136 @mikel Adding options to register observers and interceptors through ActionM…
mikel authored
24 s.add_dependency('mail', '~> 2.1.3')
031139b @dhh Homogenize gemspecs and remove the deprecated autorequire
dhh authored
25 s.add_dependency('text-format', '~> 1.0.0')
67f5d61 @wycats Add rake gemspec and gemspecs to the repo
wycats authored
26 end
Something went wrong with that request. Please try again.