Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Newer
Older
100644 78 lines (61 sloc) 1.612 kB
ba57575 Remove references to ActionDispatch::Routing::Routes in favor of Rail…
Carl Lerche authored
1 source 'http://rubygems.org'
9f01dff Get rails tests running on bundler 0.9
Carl Lerche authored
2
f2fc81f @drogus Use gemspec instead of gem rails in Gemfile
drogus authored
3 gemspec
9f01dff Get rails tests running on bundler 0.9
Carl Lerche authored
4
5 gem "rake", ">= 0.8.7"
a584b4c @jeremy Get rack from rails/rack.git. Introduce ci-only deps.
jeremy authored
6 gem "mocha", ">= 0.9.8"
82eff0f @spastorino Bump up rdoc to 2.5.10
spastorino authored
7 gem "rdoc", ">= 2.5.10"
9011f8f @fxn requires horo 1.0.2
fxn authored
8 gem "horo", ">= 1.0.2"
a584b4c @jeremy Get rack from rails/rack.git. Introduce ci-only deps.
jeremy authored
9
ac89275 @jeremy AR perf test: switch to mysql2, bundle faker and rbench
jeremy authored
10 # for perf tests
11 gem "faker"
12 gem "rbench"
b8ff3df @jeremy Include addressable for AR perf bench
jeremy authored
13 gem "addressable"
ac89275 @jeremy AR perf test: switch to mysql2, bundle faker and rbench
jeremy authored
14
2c4fcec @spastorino Gemfile now makes use of platforms calls with blocks instead of elsif…
spastorino authored
15 # AS
16 gem "memcache-client", ">= 1.8.5"
17
18 # AM
19 gem "text-format", "~> 1.0.0"
20
21 platforms :mri_18 do
61001e7 @spastorino group :mri deleted in favor of RUBY_ENGINE and RUBY_VERSION usage.
spastorino authored
22 gem "system_timer"
23 gem "ruby-debug", ">= 0.10.3"
ac89275 @jeremy AR perf test: switch to mysql2, bundle faker and rbench
jeremy authored
24 gem 'ruby-prof'
61001e7 @spastorino group :mri deleted in favor of RUBY_ENGINE and RUBY_VERSION usage.
spastorino authored
25 end
26
36e625d @spastorino Add ruby-debug19 for mri 1.9
spastorino authored
27 platforms :mri_19 do
89b073b @spastorino Bring back ruby-debug19 for Ruby versions < 1.9.3
spastorino authored
28 # TODO: Remove the conditional when ruby-debug19 supports Ruby >= 1.9.3
29 gem "ruby-debug19" if RUBY_VERSION < "1.9.3"
36e625d @spastorino Add ruby-debug19 for mri 1.9
spastorino authored
30 end
31
2c4fcec @spastorino Gemfile now makes use of platforms calls with blocks instead of elsif…
spastorino authored
32 platforms :ruby do
2218493 @jeremy Bundle json and yajl-ruby gems for AS::JSON testing
jeremy authored
33 gem 'json'
34 gem 'yajl-ruby'
c9b2736 @tenderlove using a merge with a Hash[] rather than a loop to add SAX parsed attr…
tenderlove authored
35 gem "nokogiri", ">= 1.4.4"
5714438 @spastorino Unforce memcache from AS
spastorino authored
36
2c4fcec @spastorino Gemfile now makes use of platforms calls with blocks instead of elsif…
spastorino authored
37 # AR
fcb2301 @spastorino Bump up nokogiri, memcache-client, sqlite3-ruby, fcgi, mail and tzinfo
spastorino authored
38 gem "sqlite3-ruby", "~> 1.3.1", :require => 'sqlite3'
c0db784 @nicksieger More accurate JRuby gem requirements
nicksieger authored
39
40 group :db do
e50bf67 @josevalim Bring pg back.
josevalim authored
41 gem "pg", ">= 0.9.0"
c0db784 @nicksieger More accurate JRuby gem requirements
nicksieger authored
42 gem "mysql", ">= 2.8.1"
4480521 @tenderlove bumping mysql2 requirement
tenderlove authored
43 gem "mysql2", ">= 0.2.6"
c0db784 @nicksieger More accurate JRuby gem requirements
nicksieger authored
44 end
2c4fcec @spastorino Gemfile now makes use of platforms calls with blocks instead of elsif…
spastorino authored
45 end
46
47 platforms :jruby do
48 gem "ruby-debug", ">= 0.10.3"
49
c0db784 @nicksieger More accurate JRuby gem requirements
nicksieger authored
50 gem "activerecord-jdbcsqlite3-adapter"
7789663 Put MySQL and Postgres in an :only block so you can gem bundle --only…
Yehuda Katz authored
51
9eeb24c @spastorino Add a TODO to remove gem "jruby-openssl" when jruby-openssl is merge …
spastorino authored
52 # This is needed by now to let tests work on JRuby
53 # TODO: When the JRuby guys merge jruby-openssl in
54 # jruby this will be removed
b9fd742 @anildigital Add jruby-openssl gem in Gemfile necessary for JRuby
anildigital authored
55 gem "jruby-openssl"
56
c0db784 @nicksieger More accurate JRuby gem requirements
nicksieger authored
57 group :db do
58 gem "activerecord-jdbcmysql-adapter"
59 gem "activerecord-jdbcpostgresql-adapter"
60 end
7789663 Put MySQL and Postgres in an :only block so you can gem bundle --only…
Yehuda Katz authored
61 end
d148092 @rsim added dependencies in Gemfile for running ActiveRecord tests with Ora…
rsim authored
62
f7faa86 @spastorino Leave env :AREL only for testing purposes
spastorino authored
63 env :AREL do
64 gem "arel", :path => ENV['AREL']
65 end
66
d148092 @rsim added dependencies in Gemfile for running ActiveRecord tests with Ora…
rsim authored
67 # gems that are necessary for ActiveRecord tests with Oracle database
68 if ENV['ORACLE_ENHANCED_PATH'] || ENV['ORACLE_ENHANCED']
69 platforms :ruby do
70 gem 'ruby-oci8', ">= 2.0.4"
71 end
72 if ENV['ORACLE_ENHANCED_PATH']
73 gem 'activerecord-oracle_enhanced-adapter', :path => ENV['ORACLE_ENHANCED_PATH']
74 else
75 gem "activerecord-oracle_enhanced-adapter", :git => "git://github.com/rsim/oracle-enhanced.git"
76 end
77 end
Something went wrong with that request. Please try again.