Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Newer
Older
100644 127 lines (103 sloc) 3.619 kB
5b9c902 @rafaelfranca Revert "Merge pull request #8341 from amatsuda/bundle_source_rubygems"
rafaelfranca authored
1 source 'https://rubygems.org'
9f01dff Get rails tests running on bundler 0.9
Carl Lerche authored
2
4eb0d58 @drogus Use gemspec instead of gem rails in Gemfile
drogus authored
3 gemspec
4
01ac234 @jeremy Pare down and simplify Active Job's rake tasks
jeremy authored
5 # We need a newish Rake since Active Job sets its test tasks' descriptions.
6 gem 'rake', '>= 10.3'
7
5294bf1 @kaspth Add gemfile entry for GlobalID until a new release is cut.
kaspth authored
8 # Active Job depends on the URI::GID::MissingModelIDError, which isn't released yet.
9 gem 'globalid', github: 'rails/globalid'
10
2b66b32 @prathamesh-sonpatki Don't autorequire mocha to avoid deprecation warnings
prathamesh-sonpatki authored
11 # This needs to be with require false as it is
12 # loaded after loading the test library to
13 # ensure correct loading order
14 gem 'mocha', '~> 0.14', require: false
15
7891cbf @leereilly Replace double quotes with single quotes
leereilly authored
16 gem 'rack-cache', '~> 1.2'
58009ac @carlosantoniodasilva Add branch to gems pointing to github so that we can use local checkouts
carlosantoniodasilva authored
17 gem 'jquery-rails', github: 'rails/jquery-rails', branch: 'master'
fa5a1b9 @josh Default generated Gemfile to coffee-rails ~> 4.1.0
josh authored
18 gem 'coffee-rails', '~> 4.1.0'
74a9b37 @rafaelfranca Always use latest turbolinks
rafaelfranca authored
19 gem 'turbolinks'
58009ac @carlosantoniodasilva Add branch to gems pointing to github so that we can use local checkouts
carlosantoniodasilva authored
20 gem 'arel', github: 'rails/arel', branch: 'master'
5140c07 @robin850 Test against the mail gem's edge
robin850 authored
21 gem 'mail', github: 'mikel/mail'
5f0b37c @tenderlove Switching rack-mount to journey.
tenderlove authored
22
a8225ee @rafaelfranca Test using sprockets 3
rafaelfranca authored
23 gem 'sprockets', '~> 3.0.0.rc.1'
ac98359 @arthurnn Use latest sprockets-rails on internal dev
arthurnn authored
24 gem 'sprockets-rails', github: 'rails/sprockets-rails', branch: 'master'
a8225ee @rafaelfranca Test using sprockets 3
rafaelfranca authored
25
53f1ab5 @tjschuck Bump version of bcrypt gem
tjschuck authored
26 # require: false so bcrypt is loaded only when has_secure_password is used.
27 # This is to avoid ActiveModel (and by extension the entire framework)
28 # being dependent on a binary library.
7008dfb @marutosi Gemfile: temporay pin "bcrypt" version and run "bundle update bcrypt"…
marutosi authored
29 gem 'bcrypt', '~> 3.1.10', require: false
53f1ab5 @tjschuck Bump version of bcrypt gem
tjschuck authored
30
2f6e389 @josevalim Make compressors lazily load.
josevalim authored
31 # This needs to be with require false to avoid
32 # it being automatically loaded by sprockets
ee686d3 @rafaelfranca Use the same uglifier version that the generated applications
rafaelfranca authored
33 gem 'uglifier', '>= 1.3.0', require: false
25d2b17 @guilleiguaran Allow to use a local copy of sprockets-rails during development
guilleiguaran authored
34
5bc98c9 @fxn defines a :doc group in the project's Rakefile, just for the sake of …
fxn authored
35 group :doc do
6049249 @fxn upgrade SDoc
fxn authored
36 gem 'sdoc', '~> 0.4.0'
6c98100 @amatsuda redcarpet 3.2.2 has an XSS vulnerability
amatsuda authored
37 gem 'redcarpet', '~> 3.2.3', platforms: :ruby
3ffa01c @sferik Make quotes in Gemfile consistent (use single quotes)
sferik authored
38 gem 'w3c_validators'
8d15e07 @fxn fix kindlerb version [ci skip]
fxn authored
39 gem 'kindlerb', '0.1.1'
5bc98c9 @fxn defines a :doc group in the project's Rakefile, just for the sake of …
fxn authored
40 end
a584b4c @jeremy Get rack from rails/rack.git. Introduce ci-only deps.
jeremy authored
41
6bf2b83 @yui-knk [ci skip] Fix `AS` and `AR` to full name
yui-knk authored
42 # ActiveSupport
032da37 @guilleiguaran Use dalli 2.2.1 or prior to fix failing tests in memcache session store
guilleiguaran authored
43 gem 'dalli', '>= 2.2.1'
2c4fcec @spastorino Gemfile now makes use of platforms calls with blocks instead of elsif…
spastorino authored
44
0c23277 @seuros Remove activejob integration tests
seuros authored
45 # ActiveJob
5d81a7d @rafaelfranca Create a group to active job gems
rafaelfranca authored
46 group :job do
47 gem 'resque', require: false
48 gem 'resque-scheduler', require: false
49 gem 'sidekiq', require: false
878d6c1 @brandonhilkert Remove version. No longer using Celluloid 0.16.
brandonhilkert authored
50 gem 'sucker_punch', require: false
5d81a7d @rafaelfranca Create a group to active job gems
rafaelfranca authored
51 gem 'delayed_job', require: false
e44cbfe @ajgrover Update queue_classic gem to use latest
ajgrover authored
52 gem 'queue_classic', require: false, platforms: :ruby
ee68786 @artofhuman Unlock sneakers adapter version
artofhuman authored
53 gem 'sneakers', require: false
5d81a7d @rafaelfranca Create a group to active job gems
rafaelfranca authored
54 gem 'que', require: false
55 gem 'backburner', require: false
56 gem 'qu-rails', github: "bkeepers/qu", branch: "master", require: false
57 gem 'qu-redis', require: false
cb78621 @cristianbica Fixed ActiveJob integration tests
cristianbica authored
58 gem 'delayed_job_active_record', require: false
175ba66 @cristianbica ActiveJob Integration Tests
cristianbica authored
59 gem 'sequel', require: false
5d81a7d @rafaelfranca Create a group to active job gems
rafaelfranca authored
60 end
0c23277 @seuros Remove activejob integration tests
seuros authored
61
a437986 @tenderlove allow people to set a local .Gemfile so that things like ruby-debug a…
tenderlove authored
62 # Add your own local bundler stuff
c4ceee8 @bogdan Fixed path to local gemfile.
bogdan authored
63 local_gemfile = File.dirname(__FILE__) + "/.Gemfile"
c10a781 @arunagw More Warnings removed for ruby trunk
arunagw authored
64 instance_eval File.read local_gemfile if File.exist? local_gemfile
29b54a4 @spastorino Bring back ruby-debug19 for Ruby versions < 1.9.3
spastorino authored
65
de1354f @spastorino Use platforms instead of conditionals in Gemfile
spastorino authored
66 group :test do
8c48cd2 @guilleiguaran Our test suite isn't ready to run in random order yet :cry:
guilleiguaran authored
67 # FIX: Our test suite isn't ready to run in random order yet
68 gem 'minitest', '< 5.3.4'
69
4ba1376 @carlosantoniodasilva Remove old mri platform entries from our Gemfile
carlosantoniodasilva authored
70 platforms :mri do
7da5d8a @sgrif Add StackProf to the test group for 2.1
sgrif authored
71 gem 'stackprof'
78b51a8 @chancancode Uncomment byebug in framework Gemfile
chancancode authored
72 gem 'byebug'
7da5d8a @sgrif Add StackProf to the test group for 2.1
sgrif authored
73 end
74
4076288 @spastorino Move benchmark-ips to test group
spastorino authored
75 gem 'benchmark-ips'
74eb848 @zhengjia remove ruby-prof for rubinius in Gemfile
zhengjia authored
76 end
77
2c4fcec @spastorino Gemfile now makes use of platforms calls with blocks instead of elsif…
spastorino authored
78 platforms :ruby do
3ffa01c @sferik Make quotes in Gemfile consistent (use single quotes)
sferik authored
79 gem 'nokogiri', '>= 1.4.5'
976a9d9 @arunagw Grouped the ruby-prof into test.
arunagw authored
80
066ae49 JRuby does not support racc, include it only in ruby platform
Francesco Rodriguez authored
81 # Needed for compiling the ActionDispatch::Journey parser
82 gem 'racc', '>=1.4.6', require: false
83
6bf2b83 @yui-knk [ci skip] Fix `AS` and `AR` to full name
yui-knk authored
84 # ActiveRecord
2fac915 @oscardelben Bumo sqlite3 gem
oscardelben authored
85 gem 'sqlite3', '~> 1.3.6'
c0db784 @nicksieger More accurate JRuby gem requirements
nicksieger authored
86
87 group :db do
aafee23 @sgrif Remove most PG specific type subclasses
sgrif authored
88 gem 'pg', '>= 0.18.0'
af43e71 @carlosantoniodasilva Bump mysql gem version to the newly 2.9.0, fix build.
carlosantoniodasilva authored
89 gem 'mysql', '>= 2.9.0'
a088ee9 @kamipo Format the time string according to the precision of the time column
kamipo authored
90 gem 'mysql2', '>= 0.3.18'
c0db784 @nicksieger More accurate JRuby gem requirements
nicksieger authored
91 end
2c4fcec @spastorino Gemfile now makes use of platforms calls with blocks instead of elsif…
spastorino authored
92 end
93
94 platforms :jruby do
160e078 @kassio upgrade jruby dependencies
kassio authored
95 gem 'json'
0a46830 @kares allow to test AR master against AR-JDBC master (with `ENV['AR_JDBC']`)
kares authored
96 if ENV['AR_JDBC']
97 gem 'activerecord-jdbcsqlite3-adapter', github: 'jruby/activerecord-jdbc-adapter', branch: 'master'
98 group :db do
99 gem 'activerecord-jdbcmysql-adapter', github: 'jruby/activerecord-jdbc-adapter', branch: 'master'
100 gem 'activerecord-jdbcpostgresql-adapter', github: 'jruby/activerecord-jdbc-adapter', branch: 'master'
101 end
102 else
103 gem 'activerecord-jdbcsqlite3-adapter', '>= 1.3.0'
104 group :db do
105 gem 'activerecord-jdbcmysql-adapter', '>= 1.3.0'
106 gem 'activerecord-jdbcpostgresql-adapter', '>= 1.3.0'
107 end
3ec6cc7 @rafaelfranca Fix the indentation :scissors:
rafaelfranca authored
108 end
7789663 Put MySQL and Postgres in an :only block so you can gem bundle --only…
Yehuda Katz authored
109 end
4e3d220 @rsim added dependencies in Gemfile for running ActiveRecord tests with Ora…
rsim authored
110
558f8aa @robin850 Set Psych as the YAML engine for Rubinius
robin850 authored
111 platforms :rbx do
112 # The rubysl-yaml gem doesn't ship with Psych by default
113 # as it needs libyaml that isn't always available.
114 gem 'psych', '~> 2.0'
115 end
116
4e3d220 @rsim added dependencies in Gemfile for running ActiveRecord tests with Ora…
rsim authored
117 # gems that are necessary for ActiveRecord tests with Oracle database
3034489 @rafaelfranca Remove the environment variables in the Gemfile
rafaelfranca authored
118 if ENV['ORACLE_ENHANCED']
4e3d220 @rsim added dependencies in Gemfile for running ActiveRecord tests with Ora…
rsim authored
119 platforms :ruby do
0068dcc @senny flexible ruby-oci8 version specification. [Gaurav Sharma]
senny authored
120 gem 'ruby-oci8', '~> 2.1'
4e3d220 @rsim added dependencies in Gemfile for running ActiveRecord tests with Ora…
rsim authored
121 end
3034489 @rafaelfranca Remove the environment variables in the Gemfile
rafaelfranca authored
122 gem 'activerecord-oracle_enhanced-adapter', github: 'rsim/oracle-enhanced', branch: 'master'
4e3d220 @rsim added dependencies in Gemfile for running ActiveRecord tests with Ora…
rsim authored
123 end
b564ffc @yahonda To support ActiveRecord unit tests for IBM DB2
yahonda authored
124
8cc70cf @yahonda Fix typo in Rakefile
yahonda authored
125 # A gem necessary for ActiveRecord tests with IBM DB
3ffa01c @sferik Make quotes in Gemfile consistent (use single quotes)
sferik authored
126 gem 'ibm_db' if ENV['IBM_DB']
Something went wrong with that request. Please try again.