Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Newer
Older
100644 86 lines (65 sloc) 2.159 kb
5b9c902 Rafael Mendonça França Revert "Merge pull request #8341 from amatsuda/bundle_source_rubygems"
rafaelfranca authored
1 source 'https://rubygems.org'
9f01dff Get rails tests running on bundler 0.9
Carl Lerche authored
2
4eb0d58 Piotr Sarnacki Use gemspec instead of gem rails in Gemfile
drogus authored
3 gemspec
4
3034489 Rafael Mendonça França Remove the environment variables in the Gemfile
rafaelfranca authored
5 gem 'arel', github: 'rails/arel', branch: 'master'
13df581 Aaron Patterson using AREL from the environment if it exists
tenderlove authored
6
c940aa6 Carlos Antonio da Silva Use new mocha version and add changelog entry for #8180
carlosantoniodasilva authored
7 gem 'mocha', '~> 0.13.0', require: false
3034489 Rafael Mendonça França Remove the environment variables in the Gemfile
rafaelfranca authored
8 gem 'rack-test', github: 'brynary/rack-test'
7891cbf Lee Reilly Replace double quotes with single quotes
leereilly authored
9 gem 'rack-cache', '~> 1.2'
3ffa01c Erik Michaels-Ober Make quotes in Gemfile consistent (use single quotes)
sferik authored
10 gem 'bcrypt-ruby', '~> 3.0.0'
1188fb1 Jeremy Kemper Upgrade to a jquery-rails that doesn't expect config.action_view.javascr...
jeremy authored
11 gem 'jquery-rails', '~> 2.1.4', github: 'rails/jquery-rails'
5c07836 Rafael Mendonça França Fix the coffee-rails dependecy version
rafaelfranca authored
12 gem 'turbolinks'
13 gem 'coffee-rails', github: 'rails/coffee-rails'
5f0b37c Aaron Patterson Switching rack-mount to journey.
tenderlove authored
14
3034489 Rafael Mendonça França Remove the environment variables in the Gemfile
rafaelfranca authored
15 gem 'journey', github: 'rails/journey', branch: 'master'
5f0b37c Aaron Patterson Switching rack-mount to journey.
tenderlove authored
16
3034489 Rafael Mendonça França Remove the environment variables in the Gemfile
rafaelfranca authored
17 gem 'activerecord-deprecated_finders', github: 'rails/activerecord-deprecated_finders', branch: 'master'
dd2c9b9 Jon Leighton add active_record_deprecated_finders as a dep
jonleighton authored
18
2f6e389 José Valim Make compressors lazily load.
josevalim authored
19 # This needs to be with require false to avoid
20 # it being automatically loaded by sprockets
bbcb625 Dmitry Vorotilin Since in sprockets-rails uglifier's version doesn't matter do the same i...
route authored
21 gem 'uglifier', require: false
25d2b17 Guillermo Iguaran Allow to use a local copy of sprockets-rails during development
guilleiguaran authored
22
d88b65f Joshua Peek Change back to official sprockets-rails
josh authored
23 gem 'sprockets-rails', github: 'rails/sprockets-rails', branch: 'master'
2b47059 Joshua Peek Add sprockets to Gemfile for testing
josh authored
24
5bc98c9 Xavier Noria defines a :doc group in the project's Rakefile, just for the sake of cla...
fxn authored
25 group :doc do
5287d36 Xavier Noria depend on voloko/sdoc again
fxn authored
26 gem 'sdoc', github: 'voloko/sdoc'
cadff7b Update redcarpet dependency
Vinny Diehl authored
27 gem 'redcarpet', '~> 2.2.2', platforms: :ruby
3ffa01c Erik Michaels-Ober Make quotes in Gemfile consistent (use single quotes)
sferik authored
28 gem 'w3c_validators'
5bc98c9 Xavier Noria defines a :doc group in the project's Rakefile, just for the sake of cla...
fxn authored
29 end
a584b4c Jeremy Kemper Get rack from rails/rack.git. Introduce ci-only deps.
jeremy authored
30
2c4fcec Santiago Pastorino Gemfile now makes use of platforms calls with blocks instead of elsif lo...
spastorino authored
31 # AS
032da37 Guillermo Iguaran Use dalli 2.2.1 or prior to fix failing tests in memcache session store
guilleiguaran authored
32 gem 'dalli', '>= 2.2.1'
2c4fcec Santiago Pastorino Gemfile now makes use of platforms calls with blocks instead of elsif lo...
spastorino authored
33
a437986 Aaron Patterson allow people to set a local .Gemfile so that things like ruby-debug are ...
tenderlove authored
34 # Add your own local bundler stuff
c4ceee8 Bogdan Gusiev Fixed path to local gemfile.
bogdan authored
35 local_gemfile = File.dirname(__FILE__) + "/.Gemfile"
36 instance_eval File.read local_gemfile if File.exists? local_gemfile
29b54a4 Santiago Pastorino Bring back ruby-debug19 for Ruby versions < 1.9.3
spastorino authored
37
74eb848 Zheng Jia remove ruby-prof for rubinius in Gemfile
zhengjia authored
38 platforms :mri do
39 group :test do
46dc6e7 Jeremy Kemper ruby-prof isn't compatible with ruby trunk after 36925
jeremy authored
40 gem 'ruby-prof', '~> 0.11.2' if RUBY_VERSION < '2.0'
154fee2 Santiago Pastorino Revert "Debugger gem doesn't work with patchlevel >= 327"
spastorino authored
41 gem 'debugger' if !ENV['TRAVIS'] && RUBY_VERSION < '2.0'
74eb848 Zheng Jia remove ruby-prof for rubinius in Gemfile
zhengjia authored
42 end
43 end
44
2c4fcec Santiago Pastorino Gemfile now makes use of platforms calls with blocks instead of elsif lo...
spastorino authored
45 platforms :ruby do
3ffa01c Erik Michaels-Ober Make quotes in Gemfile consistent (use single quotes)
sferik authored
46 gem 'yajl-ruby'
47 gem 'nokogiri', '>= 1.4.5'
976a9d9 Arun Agrawal Grouped the ruby-prof into test.
arunagw authored
48
2c4fcec Santiago Pastorino Gemfile now makes use of platforms calls with blocks instead of elsif lo...
spastorino authored
49 # AR
2fac915 Oscar Del Ben Bumo sqlite3 gem
oscardelben authored
50 gem 'sqlite3', '~> 1.3.6'
c0db784 Nick Sieger More accurate JRuby gem requirements
nicksieger authored
51
52 group :db do
3ffa01c Erik Michaels-Ober Make quotes in Gemfile consistent (use single quotes)
sferik authored
53 gem 'pg', '>= 0.11.0'
af43e71 Carlos Antonio da Silva Bump mysql gem version to the newly 2.9.0, fix build.
carlosantoniodasilva authored
54 gem 'mysql', '>= 2.9.0'
3ffa01c Erik Michaels-Ober Make quotes in Gemfile consistent (use single quotes)
sferik authored
55 gem 'mysql2', '>= 0.3.10'
c0db784 Nick Sieger More accurate JRuby gem requirements
nicksieger authored
56 end
2c4fcec Santiago Pastorino Gemfile now makes use of platforms calls with blocks instead of elsif lo...
spastorino authored
57 end
58
59 platforms :jruby do
3ffa01c Erik Michaels-Ober Make quotes in Gemfile consistent (use single quotes)
sferik authored
60 gem 'json'
61 gem 'activerecord-jdbcsqlite3-adapter', '>= 1.2.0'
7789663 Put MySQL and Postgres in an :only block so you can gem bundle --only de...
Yehuda Katz authored
62
ad13eb7 Santiago Pastorino Add a TODO to remove gem "jruby-openssl" when jruby-openssl is merge in ...
spastorino authored
63 # This is needed by now to let tests work on JRuby
64 # TODO: When the JRuby guys merge jruby-openssl in
65 # jruby this will be removed
3ffa01c Erik Michaels-Ober Make quotes in Gemfile consistent (use single quotes)
sferik authored
66 gem 'jruby-openssl'
ea30da3 Anil Wadghule Add jruby-openssl gem in Gemfile necessary for JRuby
anildigital authored
67
c0db784 Nick Sieger More accurate JRuby gem requirements
nicksieger authored
68 group :db do
3ffa01c Erik Michaels-Ober Make quotes in Gemfile consistent (use single quotes)
sferik authored
69 gem 'activerecord-jdbcmysql-adapter', '>= 1.2.0'
70 gem 'activerecord-jdbcpostgresql-adapter', '>= 1.2.0'
c0db784 Nick Sieger More accurate JRuby gem requirements
nicksieger authored
71 end
7789663 Put MySQL and Postgres in an :only block so you can gem bundle --only de...
Yehuda Katz authored
72 end
4e3d220 Raimonds Simanovskis added dependencies in Gemfile for running ActiveRecord tests with Oracle...
rsim authored
73
74 # gems that are necessary for ActiveRecord tests with Oracle database
3034489 Rafael Mendonça França Remove the environment variables in the Gemfile
rafaelfranca authored
75 if ENV['ORACLE_ENHANCED']
4e3d220 Raimonds Simanovskis added dependencies in Gemfile for running ActiveRecord tests with Oracle...
rsim authored
76 platforms :ruby do
3ffa01c Erik Michaels-Ober Make quotes in Gemfile consistent (use single quotes)
sferik authored
77 gem 'ruby-oci8', '>= 2.0.4'
4e3d220 Raimonds Simanovskis added dependencies in Gemfile for running ActiveRecord tests with Oracle...
rsim authored
78 end
3034489 Rafael Mendonça França Remove the environment variables in the Gemfile
rafaelfranca authored
79 gem 'activerecord-oracle_enhanced-adapter', github: 'rsim/oracle-enhanced', branch: 'master'
4e3d220 Raimonds Simanovskis added dependencies in Gemfile for running ActiveRecord tests with Oracle...
rsim authored
80 end
b564ffc Yasuo Honda To support ActiveRecord unit tests for IBM DB2
yahonda authored
81
8cc70cf Yasuo Honda Fix typo in Rakefile
yahonda authored
82 # A gem necessary for ActiveRecord tests with IBM DB
3ffa01c Erik Michaels-Ober Make quotes in Gemfile consistent (use single quotes)
sferik authored
83 gem 'ibm_db' if ENV['IBM_DB']
1411fc1 Jon Leighton Use benchmark/ips to measure AR performance
jonleighton authored
84
85 gem 'benchmark-ips'
Something went wrong with that request. Please try again.