Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Newer
Older
100644 28 lines (22 sloc) 1.082 kb
4bc2cbc @stefanpenner Load RAILS_VERSION relative to the gemspec file.
stefanpenner authored
1 version = File.read(File.expand_path("../RAILS_VERSION",__FILE__)).strip
f221a6f @brynary Leverage VERSION constants from gemspecs to avoid tedious updates when r...
brynary authored
2
67f5d61 @wycats Add rake gemspec and gemspecs to the repo
wycats authored
3 Gem::Specification.new do |s|
031139b @dhh Homogenize gemspecs and remove the deprecated autorequire
dhh authored
4 s.platform = Gem::Platform::RUBY
5 s.name = 'rails'
deb00bc @brynary Read Rails version from a file instead of modifying the load path and do...
brynary authored
6 s.version = version
56ea206 @jeremy Wordsmith gem descriptions
jeremy authored
7 s.summary = 'Full-stack web application framework.'
8 s.description = 'Ruby on Rails is a full-stack web framework optimized for programmer happiness and sustainable productivity. It encourages beautiful code by favoring convention over configuration.'
d956003 @dhh Neat and tidy, I say
dhh authored
9
10 s.required_ruby_version = '>= 1.8.7'
f30b7a0 @wycats Rails requires Rubygems 1.3.6
wycats authored
11 s.required_rubygems_version = ">= 1.3.6"
031139b @dhh Homogenize gemspecs and remove the deprecated autorequire
dhh authored
12
13 s.author = 'David Heinemeier Hansson'
14 s.email = 'david@loudthinking.com'
15 s.homepage = 'http://www.rubyonrails.org'
ca37865 @indirect Update the Bundler snippet for 0.9.15 and above
indirect authored
16
718542b @pixeltrix Revert "The rails gem doesn't have a lib directory - closes #1958."
pixeltrix authored
17 s.bindir = 'bin'
11fa70d @josevalim Just provide the executable for railtie. This should be fine since Rubyg...
josevalim authored
18 s.executables = []
67f5d61 @wycats Add rake gemspec and gemspecs to the repo
wycats authored
19
d956003 @dhh Neat and tidy, I say
dhh authored
20 s.add_dependency('activesupport', version)
21 s.add_dependency('actionpack', version)
22 s.add_dependency('activerecord', version)
23 s.add_dependency('activeresource', version)
24 s.add_dependency('actionmailer', version)
25 s.add_dependency('railties', version)
7cc371a Allow bundler 1.1 (and 1.2, etc.) in Rails 1.0.2 and above
Yehuda Katz authored
26 s.add_dependency('bundler', '~> 1.0')
67f5d61 @wycats Add rake gemspec and gemspecs to the repo
wycats authored
27 end
Something went wrong with that request. Please try again.