Skip to content
This repository
Browse code

Even though exempt_from_layout is no longer needed, some people are s…

…till using it. Deprecate it instead of removing.
  • Loading branch information...
commit 01186652ccc546842591ebf6e1d42225797ec5d4 1 parent 7a1bba4
Yehuda Katz wycats authored

Showing 1 changed file with 6 additions and 1 deletion. Show diff stats Hide diff stats

  1. +6 1 actionpack/lib/action_controller/deprecated/base.rb
7 actionpack/lib/action_controller/deprecated/base.rb
@@ -120,9 +120,14 @@ def filter_parameter_logging(*args, &block)
120 120
121 121 # This was moved to a plugin
122 122 def verify(*args)
123   - ActiveSupport::Deprecation.warn "verify was removed from Rails and is now available as a plugin. " <<
  123 + ActiveSupport::Deprecation.warn "verify was removed from Rails and is now available as a plugin. " \
124 124 "Please install it with `rails plugin install git://github.com/rails/verification.git`.", caller
125 125 end
  126 +
  127 + def exempt_from_layout(*)
  128 + ActiveSupport::Deprecation.warn "exempt_from_layout is no longer needed, because layouts in Rails 3 " \
  129 + "are restricted to the content-type of the template that was rendered.", caller
  130 + end
126 131 end
127 132
128 133 extend DeprecatedBehavior

0 comments on commit 0118665

Please sign in to comment.
Something went wrong with that request. Please try again.