Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Merge pull request #2744 from arunagw/mysql2_bump

Mysql2 bump
  • Loading branch information...
commit 0195846e5836a0f4981bf6b5944313b0462d6381 2 parents d7d0c25 + 941a9d0
@tenderlove tenderlove authored
View
2  Gemfile
@@ -41,7 +41,7 @@ platforms :ruby do
group :db do
gem "pg", ">= 0.9.0" unless ENV['TRAVIS'] # once pg is on travis this can be removed
gem "mysql", ">= 2.8.1"
- gem "mysql2", "~> 0.2.11"
+ gem "mysql2", "~> 0.2.13"
end
end
View
2  railties/lib/rails/generators/rails/app/app_generator.rb
@@ -425,7 +425,7 @@ def convert_database_option_for_jruby
def version_constraint_for_database_gem
case options[:database]
- when "mysql" then "~> 0.2.11"
+ when "mysql" then "~> 0.2.13"
else nil
end
end
View
2  railties/test/generators/app_generator_test.rb
@@ -167,7 +167,7 @@ def test_config_another_database
unless defined?(JRUBY_VERSION)
# Ensure that the mysql2 gem is listed with a compatible version of the
# mysql2 gem
- assert_file "Gemfile", /^gem\s+["']mysql2["'],\s*'~> 0.2.11'$/
+ assert_file "Gemfile", /^gem\s+["']mysql2["'],\s*'~> 0.2.13'$/
else
assert_file "Gemfile", /^gem\s+["']activerecord-jdbcmysql-adapter["']$/
end
Please sign in to comment.
Something went wrong with that request. Please try again.