Permalink
Browse files

Ruby 1.9 compat: don't use obsolete ParseDate

git-svn-id: http://svn-commit.rubyonrails.org/rails/trunk@8490 5ecf4fe2-1ee6-0310-87b1-e25e094e27de
  • Loading branch information...
1 parent d760d88 commit 05a4db5ecabeca9e04a48baffc7b0ef2febc3d70 @jeremy jeremy committed Dec 27, 2007
Showing with 4 additions and 4 deletions.
  1. +4 −4 activesupport/lib/active_support/core_ext/string/conversions.rb
@@ -1,4 +1,4 @@
-require 'parsedate'
+require 'date'
module ActiveSupport #:nodoc:
module CoreExtensions #:nodoc:
@@ -12,15 +12,15 @@ def ord
# Form can be either :utc (default) or :local.
def to_time(form = :utc)
- ::Time.send("#{form}_time", *ParseDate.parsedate(self)[0..5].map {|arg| arg || 0})
+ ::Time.send("#{form}_time", *::Date._parse(self, false).values_at(:year, :mon, :mday, :hour, :min, :sec).map { |arg| arg || 0 })
end
def to_date
- ::Date.new(*ParseDate.parsedate(self)[0..2])
+ ::Date.new(*::Date._parse(self, false).values_at(:year, :mon, :mday))
end
def to_datetime
- ::DateTime.civil(*ParseDate.parsedate(self)[0..5].map {|arg| arg || 0} << 0)
+ ::DateTime.civil(*::Date._parse(self, false).values_at(:year, :mon, :mday, :hour, :min, :sec).map { |arg| arg || 0 })
end
end
end

0 comments on commit 05a4db5

Please sign in to comment.