Permalink
Browse files

Updated bug report templates

* use `Minitest::Test` instead of deprectaed `MiniTest::Unit::TestCase`

 [ci skip]
  • Loading branch information...
1 parent 7a31388 commit 0643daaf4c5a0111842d3421a2b4fecac51916c5 @pftg pftg committed Aug 21, 2013
@@ -25,7 +25,7 @@ class Comment < ActiveRecord::Base
belongs_to :post
end
-class BugTest < MiniTest::Unit::TestCase
+class BugTest < Minitest::Test
@robin850

robin850 Sep 7, 2013

Member

I think that this change should be reverted or we should add gem 'minitest', '~> 5.0since by default ActiveRecord 4.0.0 will depend on Minitest 4.x. What do you think ?

@pftg

pftg Sep 7, 2013

Contributor

Yes, only for this file. I missed this.

@robin850

robin850 Sep 7, 2013

Member

Ok, I've opened #12157. Sorry for disturbance and actually I'm saying bullshit, we can't install Minitest 5 with Rails 4.0. 😊

def test_association_stuff
post = Post.create!
post.comments << Comment.create!
@@ -36,7 +36,7 @@ class Comment < ActiveRecord::Base
belongs_to :post
end
-class BugTest < MiniTest::Unit::TestCase
+class BugTest < Minitest::Test
def test_association_stuff
post = Post.create!
post.comments << Comment.create!

0 comments on commit 0643daa

Please sign in to comment.