Permalink
Browse files

Deprecate "Allow frameworks to be required by their gem name"

This has just been confusing. Better to educate than band-aid.

This deprecates commit 18a2427.
Originally from http://dev.rubyonrails.org/ticket/8845 [drnic]
  • Loading branch information...
1 parent c5e3309 commit 08d15f86c447fea31132d11df03ff5df41650f50 @jeremy jeremy committed Sep 12, 2009
@@ -1 +1,2 @@
require 'action_mailer'
+ActiveSupport::Deprecation.warn 'require "actionmailer" is deprecated and will be removed in Rails 3. Use require "action_mailer" instead.'
@@ -1 +1,2 @@
require 'action_pack'
+ActiveSupport::Deprecation.warn 'require "actionpack" is deprecated and will be removed in Rails 3. Use require "action_pack" instead.'
@@ -1 +1,2 @@
require 'active_record'
+ActiveSupport::Deprecation.warn 'require "activerecord" is deprecated and will be removed in Rails 3. Use require "active_record" instead.'
@@ -1 +1,2 @@
require 'active_resource'
+ActiveSupport::Deprecation.warn 'require "activeresource" is deprecated and will be removed in Rails 3. Use require "active_resource" instead.'
@@ -1 +1,2 @@
require 'active_support'
+ActiveSupport::Deprecation.warn 'require "activesupport" is deprecated and will be removed in Rails 3. Use require "active_support" instead.'

2 comments on commit 08d15f8

Contributor

alloy commented on 08d15f8 Sep 12, 2009

Hooray!

Member

mislav replied Sep 14, 2009

Wohoo!

Please sign in to comment.