Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

just < 1.9 is fine and 1.9.1 is not supported

  • Loading branch information...
commit 092a4e296de5b69f06edac2fe0993e2a30e33555 1 parent c0b4db0
@spastorino spastorino authored
Showing with 3 additions and 3 deletions.
  1. +3 −3 activesupport/test/ordered_hash_test.rb
View
6 activesupport/test/ordered_hash_test.rb
@@ -80,7 +80,7 @@ def test_each_key
keys = []
assert_equal @ordered_hash, @ordered_hash.each_key { |k| keys << k }
assert_equal @keys, keys
- expected_class = RUBY_VERSION < '1.9.1' ? Enumerable::Enumerator : Enumerator
+ expected_class = RUBY_VERSION < '1.9' ? Enumerable::Enumerator : Enumerator
assert_kind_of expected_class, @ordered_hash.each_key
end
@@ -88,7 +88,7 @@ def test_each_value
values = []
assert_equal @ordered_hash, @ordered_hash.each_value { |v| values << v }
assert_equal @values, values
- expected_class = RUBY_VERSION < '1.9.1' ? Enumerable::Enumerator : Enumerator
+ expected_class = RUBY_VERSION < '1.9' ? Enumerable::Enumerator : Enumerator
assert_kind_of expected_class, @ordered_hash.each_value
end
@@ -96,7 +96,7 @@ def test_each
values = []
assert_equal @ordered_hash, @ordered_hash.each {|key, value| values << value}
assert_equal @values, values
- expected_class = RUBY_VERSION < '1.9.1' ? Enumerable::Enumerator : Enumerator
+ expected_class = RUBY_VERSION < '1.9' ? Enumerable::Enumerator : Enumerator
assert_kind_of expected_class, @ordered_hash.each
end
Please sign in to comment.
Something went wrong with that request. Please try again.