Browse files

Debugger gem doesn't work with patchlevel < 327

  • Loading branch information...
1 parent 2f3d81c commit 0ecd4640664c4723323d6fff5760dc4d833d7eb9 @spastorino spastorino committed Nov 12, 2012
Showing with 2 additions and 1 deletion.
  1. +2 −1 Gemfile
3 Gemfile
@@ -42,7 +42,8 @@ instance_eval local_gemfile if File.exists? local_gemfile
platforms :mri do
group :test do
gem 'ruby-prof', '~> 0.11.2' if RUBY_VERSION < '2.0'
- gem 'debugger' if !ENV['TRAVIS'] && RUBY_VERSION < '2.0'
+ gem 'debugger' if !ENV['TRAVIS'] && RUBY_VERSION < '2.0' && RUBY_PATCHLEVEL < 327

5 comments on commit 0ecd464


Do you mean `Debugger gem doesn't work with patchlevel =>327' ?

Ruby on Rails member

Ruby's patch level. It didn't work until then.


Thanks for the comment.

I was thinking this commit comes from debugger-linecache installation failure with ruby 1.9.3p327. See

If so this commit itself handles this failure correctly but this commit message might be misleading.

Ruby on Rails member

Yeah the commit message is wrong :), sorry about that.


Thanks. Now everything is clear to me.

Please sign in to comment.