Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Just provide the executable for railtie. This should be fine since Ru…

…bygems now warns before overriding them.
  • Loading branch information...
commit 11fa70dd0903a75f2a507dd609ea640e8ec99373 1 parent 63082af
@josevalim josevalim authored
Showing with 7 additions and 9 deletions.
  1. +0 −7 bin/rails
  2. +1 −1  rails.gemspec
  3. +6 −1 railties/bin/rails
View
7 bin/rails
@@ -1,7 +0,0 @@
-#!/usr/bin/env ruby
-
-if File.exists?(File.join(File.expand_path('../..', __FILE__), '.git'))
- railties_path = File.expand_path('../../railties/lib', __FILE__)
- $:.unshift(railties_path)
-end
-require "rails/cli"
View
2  rails.gemspec
@@ -15,7 +15,7 @@ Gem::Specification.new do |s|
s.homepage = 'http://www.rubyonrails.org'
s.bindir = 'bin'
- s.executables = ['rails']
+ s.executables = []
s.add_dependency('activesupport', version)
s.add_dependency('actionpack', version)
View
7 railties/bin/rails
@@ -1,2 +1,7 @@
#!/usr/bin/env ruby
-require "rails/cli"
+
+if File.exists?(File.join(File.expand_path('../../..', __FILE__), '.git'))
+ railties_path = File.expand_path('../../lib', __FILE__)
+ $:.unshift(railties_path)
+end
+require "rails/cli"
Please sign in to comment.
Something went wrong with that request. Please try again.