Skip to content
Permalink
Browse files

Support Rails with sass-rails 6

  • Loading branch information...
rafaelfranca committed Aug 16, 2019
1 parent 5e2d3d1 commit 1953e0e1ace0a1790e8fe5ee0bca159637d67f61
Showing with 19 additions and 19 deletions.
  1. +18 −18 Gemfile.lock
  2. +1 −1 railties/lib/rails/generators/app_base.rb
@@ -191,7 +191,7 @@ GEM
coffee-script-source
execjs
coffee-script-source (1.12.2)
concurrent-ruby (1.1.4)
concurrent-ruby (1.1.5)
connection_pool (2.2.2)
cookiejar (0.3.3)
crack (0.4.3)
@@ -341,12 +341,12 @@ GEM
mysql2 (0.5.2-x86-mingw32)
nio4r (2.3.1)
nio4r (2.3.1-java)
nokogiri (1.10.3)
nokogiri (1.10.4)
mini_portile2 (~> 2.4.0)
nokogiri (1.10.3-java)
nokogiri (1.10.3-x64-mingw32)
nokogiri (1.10.4-java)
nokogiri (1.10.4-x64-mingw32)
mini_portile2 (~> 2.4.0)
nokogiri (1.10.3-x86-mingw32)
nokogiri (1.10.4-x86-mingw32)
mini_portile2 (~> 2.4.0)
os (1.0.0)
parallel (1.17.0)
@@ -381,7 +381,7 @@ GEM
rails-html-sanitizer (1.2.0)
loofah (~> 2.2, >= 2.2.2)
rainbow (3.0.0)
rake (12.3.2)
rake (12.3.3)
rb-fsevent (0.10.3)
rb-inotify (0.10.0)
ffi (~> 1.0)
@@ -427,17 +427,17 @@ GEM
rufus-scheduler (3.6.0)
fugit (~> 1.1, >= 1.1.6)
safe_yaml (1.0.4)
sass (3.7.2)
sass-listen (~> 4.0.0)
sass-listen (4.0.0)
rb-fsevent (~> 0.9, >= 0.9.4)
rb-inotify (~> 0.9, >= 0.9.7)
sass-rails (5.0.7)
railties (>= 4.0.0, < 6)
sass (~> 3.1)
sprockets (>= 2.8, < 4.0)
sprockets-rails (>= 2.0, < 4.0)
tilt (>= 1.1, < 3)
sass-rails (6.0.0)
sassc-rails (~> 2.1, >= 2.1.1)
sassc (2.0.1)
ffi (~> 1.9)
rake
sassc-rails (2.1.2)
railties (>= 4.0.0)
sassc (>= 2.0)
sprockets (> 3.0)
sprockets-rails
tilt
sdoc (1.0.0)
rdoc (>= 5.0)
selenium-webdriver (3.142.3)
@@ -525,7 +525,7 @@ GEM
websocket-extensions (0.1.3)
xpath (3.2.0)
nokogiri (~> 1.8)
zeitwerk (2.1.8)
zeitwerk (2.1.9)

PLATFORMS
java
@@ -306,7 +306,7 @@ def rails_version_specifier(gem_version = Rails.gem_version)
def assets_gemfile_entry
return [] if options[:skip_sprockets]

GemfileEntry.version("sass-rails", ">= 5", "Use SCSS for stylesheets")
GemfileEntry.version("sass-rails", ">= 6", "Use SCSS for stylesheets")
end

def webpacker_gemfile_entry

0 comments on commit 1953e0e

Please sign in to comment.
You can’t perform that action at this time.