Skip to content
This repository
Browse code

Slicker way of quiting on less than Ruby 1.8.2

git-svn-id: http://svn-commit.rubyonrails.org/rails/trunk@810 5ecf4fe2-1ee6-0310-87b1-e25e094e27de
  • Loading branch information...
commit 19dddf24a63bd8a715ca47955963ba77d174d830 1 parent 38ea84a
David Heinemeier Hansson dhh authored

Showing 1 changed file with 1 addition and 1 deletion. Show diff stats Hide diff stats

  1. +1 1  railties/bin/rails
2  railties/bin/rails
... ... @@ -1,6 +1,6 @@
1 1 #!/usr/local/bin/ruby
2 2
3   -puts "Rails requires Ruby 1.8.2" and exit if RUBY_VERSION < "1.8.2"
  3 +abort "Rails requires Ruby 1.8.2" if RUBY_VERSION < "1.8.2"
4 4
5 5 require File.dirname(__FILE__) + '/../lib/rails_generator'
6 6 require 'rails_generator/scripts/generate'

0 comments on commit 19dddf2

Please sign in to comment.
Something went wrong with that request. Please try again.