Permalink
Browse files

Lock ruby gems for Ruby 1.9.3 and 2.0.0

Ruby gems 2.7.3 causes the following error in Railties tests on Ruby
1.9.3 and 2.0.0:

```
1) Failure:
ApplicationTests::BinSetupTest#test_bin_setup_output
[test/application/bin_setup_test.rb:48]:
--- expected
+++ actual
@@ -1,4 +1,5 @@
"== Installing dependencies ==
+YAML safe loading is not available. Please upgrade psych to a
version that supports safe loading (>= 2.0).
The Gemfile's dependencies are satisfied
```

I'm not aware of a way to make travis set different ruby gems versions
for specific ruby versions. I really don't think it matters too much
since this is just on travis and we're not releasing Rails 4.2 much
anymore. I want to maintain a green build though.
  • Loading branch information...
eileencodes committed Dec 8, 2017
1 parent ca56568 commit 1b016af1f64de0d3384e48353b3df759dba3a5f1
Showing with 1 addition and 0 deletions.
  1. +1 −0 .travis.yml
View
@@ -4,6 +4,7 @@ script: 'ci/travis.rb'
before_install:
- "rvm current | grep 'jruby' && export AR_JDBC=true || echo"
- "rm ${BUNDLE_GEMFILE}.lock"
- "gem update --system 2.6.13"
- "gem update bundler"
before_script:
- bundle update

0 comments on commit 1b016af

Please sign in to comment.