Permalink
Browse files

Bump to Bundler 0.9.8. Remark on RubyGems 1.3.6 fix.

  • Loading branch information...
1 parent 6e78fdb commit 1ff7e566fdd09675877753063487b0589be53aac @jeremy jeremy committed Feb 26, 2010
Showing with 4 additions and 5 deletions.
  1. +1 −1 ci/ci_build.rb
  2. +1 −1 rails.gemspec
  3. +2 −3 rails3b.gemspec
View
@@ -19,7 +19,7 @@ def rake(*tasks)
build_results = {}
# Install required version of bundler.
-bundler_install_cmd = "gem install bundler -v 0.9.6 --no-ri --no-rdoc"
+bundler_install_cmd = "gem install bundler -v 0.9.8 --no-ri --no-rdoc"
puts "Running command: #{bundler_install_cmd}"
build_results[:install_bundler] = system bundler_install_cmd
View
@@ -20,5 +20,5 @@ Gem::Specification.new do |s|
s.add_dependency('activeresource', '= 3.0.0.beta1')
s.add_dependency('actionmailer', '= 3.0.0.beta1')
s.add_dependency('railties', '= 3.0.0.beta1')
- s.add_dependency('bundler', '>= 0.9.3')
+ s.add_dependency('bundler', '>= 0.9.8')
end
View
@@ -2,8 +2,7 @@ Gem::Specification.new do |s|
s.platform = Gem::Platform::RUBY
s.name = 'rails3b'
s.version = '3.0.1'
- s.summary = 'Just the Rails 3 beta dependencies. Works around prerelease RubyGems bug.'
- s.description = 'My kingdom for working dependencies.'
+ s.summary = 'Just the Rails 3 beta dependencies. Works around prerelease RubyGems bug in versions before 1.3.6.'
s.required_ruby_version = '>= 1.8.7'
s.author = 'Jeremy Kemper'
@@ -22,7 +21,7 @@ Gem::Specification.new do |s|
s.add_dependency('tzinfo', '~> 0.3.16')
s.add_dependency('builder', '~> 2.1.2')
s.add_dependency('memcache-client', '~> 1.7.5')
- s.add_dependency('bundler', '>= 0.9.2')
+ s.add_dependency('bundler', '>= 0.9.8')
s.add_dependency('rake', '>= 0.8.3')
s.add_dependency('thor', '~> 0.13')
end

0 comments on commit 1ff7e56

Please sign in to comment.