Permalink
Browse files

Bring back ruby-debug19 for Ruby versions < 1.9.3

  • Loading branch information...
1 parent 00261a1 commit 29b54a41d9cd9b5b8902429be4adedf4a296fa9d @spastorino spastorino committed Nov 5, 2010
Showing with 5 additions and 0 deletions.
  1. +5 −0 Gemfile
View
@@ -31,6 +31,11 @@ platforms :mri_18 do
gem 'ruby-prof'
end
+platforms :mri_19 do
+ # TODO: Remove the conditional when ruby-debug19 supports Ruby >= 1.9.3
+ gem "ruby-debug19" if RUBY_VERSION < "1.9.3"
+end
+
platforms :ruby do
gem 'json'
gem 'yajl-ruby'

2 comments on commit 29b54a4

Contributor

joneslee85 replied Nov 6, 2010

what's alternative to ruby-debug19 for ruby 1.9.3? Will Rails provide some debugger?

Owner

spastorino replied Nov 6, 2010

I guess will be the same gem.
The problem is that the gem is not working on 1.9.3 we have to wait for a fix.

Please sign in to comment.