Permalink
Browse files

Use instead of STDERR in boot.rb. Closes #9988 [thewoolleyman]

git-svn-id: http://svn-commit.rubyonrails.org/rails/trunk@8021 5ecf4fe2-1ee6-0310-87b1-e25e094e27de
  • Loading branch information...
1 parent 4237883 commit 2bfd6772a4f3f9e0ff395cfd415dafbc1c9dec80 @jeremy jeremy committed Oct 26, 2007
Showing with 3 additions and 3 deletions.
  1. +3 −3 railties/environments/boot.rb
@@ -49,7 +49,7 @@ def load_rails_gem
gem 'rails'
end
rescue Gem::LoadError => load_error
- STDERR.puts %(Missing the Rails #{version} gem. Please `gem install -v=#{version} rails`, update your RAILS_GEM_VERSION setting in config/environment.rb for the Rails version you do have installed, or comment out RAILS_GEM_VERSION to use the latest version installed.)
+ $stderr.puts %(Missing the Rails #{version} gem. Please `gem install -v=#{version} rails`, update your RAILS_GEM_VERSION setting in config/environment.rb for the Rails version you do have installed, or comment out RAILS_GEM_VERSION to use the latest version installed.)
exit 1
end
@@ -72,12 +72,12 @@ def load_rubygems
require 'rubygems'
unless rubygems_version >= '0.9.4'
- STDERR.puts %(Rails requires RubyGems >= 0.9.4 (you have #{rubygems_version}). Please `gem update --system` and try again.)
+ $stderr.puts %(Rails requires RubyGems >= 0.9.4 (you have #{rubygems_version}). Please `gem update --system` and try again.)
exit 1
end
rescue LoadError
- STDERR.puts %(Rails requires RubyGems >= 0.9.4. Please install RubyGems and try again: http://rubygems.rubyforge.org)
+ $stderr.puts %(Rails requires RubyGems >= 0.9.4. Please install RubyGems and try again: http://rubygems.rubyforge.org)
exit 1
end

0 comments on commit 2bfd677

Please sign in to comment.