Skip to content

Commit

Permalink
Upgrade to Ruby 2.2.2
Browse files Browse the repository at this point in the history
and fix the grammar in the ruby_version_check.rb user message.
  • Loading branch information
jonatack committed Apr 14, 2015
1 parent 3472662 commit 32f7491
Show file tree
Hide file tree
Showing 12 changed files with 15 additions and 15 deletions.
2 changes: 1 addition & 1 deletion actionmailer/actionmailer.gemspec
Original file line number Diff line number Diff line change
Expand Up @@ -7,7 +7,7 @@ Gem::Specification.new do |s|
s.summary = 'Email composition, delivery, and receiving framework (part of Rails).'
s.description = 'Email on Rails. Compose, deliver, receive, and test emails using the familiar controller/view pattern. First-class support for multipart email and attachments.'

s.required_ruby_version = '>= 2.2.1'
s.required_ruby_version = '>= 2.2.2'

s.license = 'MIT'

Expand Down
2 changes: 1 addition & 1 deletion actionpack/actionpack.gemspec
Original file line number Diff line number Diff line change
Expand Up @@ -7,7 +7,7 @@ Gem::Specification.new do |s|
s.summary = 'Web-flow and rendering framework putting the VC in MVC (part of Rails).'
s.description = 'Web apps on Rails. Simple, battle-tested conventions for building and testing MVC web applications. Works with any Rack-compatible server.'

s.required_ruby_version = '>= 2.2.1'
s.required_ruby_version = '>= 2.2.2'

s.license = 'MIT'

Expand Down
2 changes: 1 addition & 1 deletion actionview/actionview.gemspec
Original file line number Diff line number Diff line change
Expand Up @@ -7,7 +7,7 @@ Gem::Specification.new do |s|
s.summary = 'Rendering framework putting the V in MVC (part of Rails).'
s.description = 'Simple, battle-tested conventions and helpers for building web pages.'

s.required_ruby_version = '>= 2.2.1'
s.required_ruby_version = '>= 2.2.2'

s.license = 'MIT'

Expand Down
2 changes: 1 addition & 1 deletion activejob/activejob.gemspec
Original file line number Diff line number Diff line change
Expand Up @@ -7,7 +7,7 @@ Gem::Specification.new do |s|
s.summary = 'Job framework with pluggable queues.'
s.description = 'Declare job classes that can be run by a variety of queueing backends.'

s.required_ruby_version = '>= 2.2.1'
s.required_ruby_version = '>= 2.2.2'

s.license = 'MIT'

Expand Down
2 changes: 1 addition & 1 deletion activemodel/activemodel.gemspec
Original file line number Diff line number Diff line change
Expand Up @@ -7,7 +7,7 @@ Gem::Specification.new do |s|
s.summary = 'A toolkit for building modeling frameworks (part of Rails).'
s.description = 'A toolkit for building modeling frameworks like Active Record. Rich support for attributes, callbacks, validations, serialization, internationalization, and testing.'

s.required_ruby_version = '>= 2.2.1'
s.required_ruby_version = '>= 2.2.2'

s.license = 'MIT'

Expand Down
2 changes: 1 addition & 1 deletion activerecord/activerecord.gemspec
Original file line number Diff line number Diff line change
Expand Up @@ -7,7 +7,7 @@ Gem::Specification.new do |s|
s.summary = 'Object-relational mapper framework (part of Rails).'
s.description = 'Databases on Rails. Build a persistent domain model by mapping database tables to Ruby classes. Strong conventions for associations, validations, aggregations, migrations, and testing come baked-in.'

s.required_ruby_version = '>= 2.2.1'
s.required_ruby_version = '>= 2.2.2'

s.license = 'MIT'

Expand Down
2 changes: 1 addition & 1 deletion activesupport/activesupport.gemspec
Original file line number Diff line number Diff line change
Expand Up @@ -7,7 +7,7 @@ Gem::Specification.new do |s|
s.summary = 'A toolkit of support libraries and Ruby core extensions extracted from the Rails framework.'
s.description = 'A toolkit of support libraries and Ruby core extensions extracted from the Rails framework. Rich support for multibyte strings, internationalization, time zones, and testing.'

s.required_ruby_version = '>= 2.2.1'
s.required_ruby_version = '>= 2.2.2'

s.license = 'MIT'

Expand Down
4 changes: 2 additions & 2 deletions guides/source/command_line.md
Original file line number Diff line number Diff line change
Expand Up @@ -402,8 +402,8 @@ INFO: You can also use `rake -T` to get the list of tasks.
$ bin/rake about
About your application's environment
Rails version 5.0.0
Ruby version 2.2.1 (x86_64-linux)
RubyGems version 2.4.5
Ruby version 2.2.2 (x86_64-linux)
RubyGems version 2.4.6
Rack version 1.6
JavaScript Runtime Node.js (V8)
Middleware Rack::Sendfile, ActionDispatch::Static, Rack::Lock, #<ActiveSupport::Cache::Strategy::LocalCache::Middleware:0x007ffd131a7c88>, Rack::Runtime, Rack::MethodOverride, ActionDispatch::RequestId, Rails::Rack::Logger, ActionDispatch::ShowExceptions, ActionDispatch::DebugExceptions, ActionDispatch::RemoteIp, ActionDispatch::Reloader, ActionDispatch::Callbacks, ActiveRecord::Migration::CheckPending, ActiveRecord::ConnectionAdapters::ConnectionManagement, ActiveRecord::QueryCache, ActionDispatch::Cookies, ActionDispatch::Session::CookieStore, ActionDispatch::Flash, ActionDispatch::ParamsParser, Rack::Head, Rack::ConditionalGet, Rack::ETag
Expand Down
2 changes: 1 addition & 1 deletion guides/source/upgrading_ruby_on_rails.md
Original file line number Diff line number Diff line change
Expand Up @@ -20,7 +20,7 @@ The best way to be sure that your application still works after upgrading is to

Rails generally stays close to the latest released Ruby version when it's released:

* Rails 5 requires Ruby 2.2.1 or newer.
* Rails 5 requires Ruby 2.2.2 or newer.
* Rails 4 prefers Ruby 2.0 and requires 1.9.3 or newer.
* Rails 3.2.x is the last branch to support Ruby 1.8.7.
* Rails 3 and above require Ruby 1.8.7 or higher. Support for all of the previous Ruby versions has been dropped officially. You should upgrade as early as possible.
Expand Down
2 changes: 1 addition & 1 deletion rails.gemspec
Original file line number Diff line number Diff line change
Expand Up @@ -7,7 +7,7 @@ Gem::Specification.new do |s|
s.summary = 'Full-stack web application framework.'
s.description = 'Ruby on Rails is a full-stack web framework optimized for programmer happiness and sustainable productivity. It encourages beautiful code by favoring convention over configuration.'

s.required_ruby_version = '>= 2.2.1'
s.required_ruby_version = '>= 2.2.2'
s.required_rubygems_version = '>= 1.8.11'

s.license = 'MIT'
Expand Down
6 changes: 3 additions & 3 deletions railties/lib/rails/ruby_version_check.rb
Original file line number Diff line number Diff line change
@@ -1,13 +1,13 @@
if RUBY_VERSION < '2.2.1' && RUBY_ENGINE == 'ruby'
if RUBY_VERSION < '2.2.2' && RUBY_ENGINE == 'ruby'
desc = defined?(RUBY_DESCRIPTION) ? RUBY_DESCRIPTION : "ruby #{RUBY_VERSION} (#{RUBY_RELEASE_DATE})"
abort <<-end_message
Rails 5 requires to run on Ruby 2.2.1 or newer.
Rails 5 requires Ruby 2.2.2 or newer.
You're running
#{desc}
Please upgrade to Ruby 2.2.1 or newer to continue.
Please upgrade to Ruby 2.2.2 or newer to continue.
end_message
end
2 changes: 1 addition & 1 deletion railties/railties.gemspec
Original file line number Diff line number Diff line change
Expand Up @@ -7,7 +7,7 @@ Gem::Specification.new do |s|
s.summary = 'Tools for creating, working with, and running Rails applications.'
s.description = 'Rails internals: application bootup, plugins, generators, and rake tasks.'

s.required_ruby_version = '>= 2.2.1'
s.required_ruby_version = '>= 2.2.2'

s.license = 'MIT'

Expand Down

0 comments on commit 32f7491

Please sign in to comment.