Permalink
Browse files

Update supported ruby versions error message in ruby_version_check.rb

  • Loading branch information...
lihanli committed Oct 3, 2012
1 parent 288885f commit 36261c816592ab34c41dad82d1e6396d979e0672
Showing with 6 additions and 2 deletions.
  1. +4 −0 railties/CHANGELOG.md
  2. +2 −2 railties/lib/rails/ruby_version_check.rb
View
@@ -1,3 +1,7 @@
## Rails 3.2.9 (unreleased)
* Update supported ruby versions error message in ruby_version_check.rb *Lihan Li*
## Rails 3.2.8 (Aug 9, 2012) ##
* ERB scaffold generator use the `:data => { :confirm => "Text" }` syntax instead of `:confirm`.
@@ -2,7 +2,7 @@
desc = defined?(RUBY_DESCRIPTION) ? RUBY_DESCRIPTION : "ruby #{RUBY_VERSION} (#{RUBY_RELEASE_DATE})"
abort <<-end_message
Rails 3 requires Ruby 1.8.7 or 1.9.2.
Rails 3 requires Ruby 1.8.7 or >= 1.9.2.
You're running
#{desc}
@@ -14,7 +14,7 @@
$stderr.puts <<-end_message
Rails 3 doesn't officially support Ruby 1.9.1 since recent stable
releases have segfaulted the test suite. Please upgrade to Ruby 1.9.2.
releases have segfaulted the test suite. Please upgrade to Ruby 1.9.2 or later.
You're running
#{RUBY_DESCRIPTION}

0 comments on commit 36261c8

Please sign in to comment.