Permalink
Browse files

Add release notes URL to vendor/plugins deprecation warning. Update C…

…HANGELOG.
  • Loading branch information...
1 parent d9e0c4a commit 49a1017235c4b73b4cdc718ee882f4cd9a7fb195 @jeremy jeremy committed Jan 4, 2012
Showing with 2 additions and 2 deletions.
  1. +1 −1 railties/CHANGELOG.md
  2. +1 −1 railties/lib/rails/plugin.rb
View
@@ -1,6 +1,6 @@
## Rails 3.2.0 (unreleased) ##
-* Rails::Plugin is deprecated and will be removed in Rails 4.0. Instead of adding plugins to vendor/plugins use gems or bundler with path or git dependencies. *Santiago Pastorino*
+* Rails 2.3-style plugins in vendor/plugins are deprecated and will be removed in Rails 4.0. Move them out of vendor/plugins and bundle them in your Gemfile, or fold them in to your app as lib/myplugin/* and config/initializers/myplugin.rb. *Santiago Pastorino*
* Guides are available as a single .mobi for the Kindle and free Kindle readers apps. *Michael Pearson & Xavier Noria*
@@ -53,7 +53,7 @@ def railtie_name
end
def initialize(root)
- ActiveSupport::Deprecation.warn "You have Rails 2.3-style plugins in vendor/plugins! Support for these plugins will be removed in Rails 4.0. Move them out and bundle them in your Gemfile, or fold them in to your app as lib/myplugin/* and config/initializers/myplugin.rb."
+ ActiveSupport::Deprecation.warn "You have Rails 2.3-style plugins in vendor/plugins! Support for these plugins will be removed in Rails 4.0. Move them out and bundle them in your Gemfile, or fold them in to your app as lib/myplugin/* and config/initializers/myplugin.rb. See the release notes for more on this: http://weblog.rubyonrails.org/2012/01/04/rails-3-2-0-rc2-has-been-released"
@name = File.basename(root).to_sym
config.root = root
end

0 comments on commit 49a1017

Please sign in to comment.