Permalink
Browse files

Fixed that no gems installed would cause error (closes #11459) [thech…

…risoshow]

git-svn-id: http://svn-commit.rubyonrails.org/rails/trunk@9112 5ecf4fe2-1ee6-0310-87b1-e25e094e27de
  • Loading branch information...
1 parent c57254d commit 4aca503d0e7595efde10e5b225eb11937693b117 @dhh dhh committed Mar 28, 2008
Showing with 1 addition and 1 deletion.
  1. +1 −1 railties/lib/rails/plugin/locator.rb
@@ -86,7 +86,7 @@ def plugins
require "rubygems/dependency_list"
deps = Gem::DependencyList.new
- deps.add(*specs)
+ deps.add(*specs) unless specs.empty?
deps.dependency_order.collect do |spec|
Rails::GemPlugin.new(spec)

0 comments on commit 4aca503

Please sign in to comment.