Skip to content
This repository
Browse code

Mysql2 version bump!

I saw one bug fixed here 

brianmario/mysql2@e60599b
  • Loading branch information...
commit 4e72f59c5d1c570f043fc54a088f4db23029173e 1 parent 2ba0309
Arun Agrawal arunagw authored
2  Gemfile
@@ -41,7 +41,7 @@ platforms :ruby do
41 41 group :db do
42 42 gem "pg", ">= 0.9.0" unless ENV['TRAVIS'] # once pg is on travis this can be removed
43 43 gem "mysql", ">= 2.8.1"
44   - gem "mysql2", "~> 0.2.13"
  44 + gem "mysql2", "~> 0.2.17"
45 45 end
46 46 end
47 47
2  railties/lib/rails/generators/rails/app/app_generator.rb
@@ -425,7 +425,7 @@ def convert_database_option_for_jruby
425 425
426 426 def version_constraint_for_database_gem
427 427 case options[:database]
428   - when "mysql" then "~> 0.2.13"
  428 + when "mysql" then "~> 0.2.17"
429 429 else nil
430 430 end
431 431 end
2  railties/test/generators/app_generator_test.rb
@@ -167,7 +167,7 @@ def test_config_another_database
167 167 unless defined?(JRUBY_VERSION)
168 168 # Ensure that the mysql2 gem is listed with a compatible version of the
169 169 # mysql2 gem
170   - assert_file "Gemfile", /^gem\s+["']mysql2["'],\s*'~> 0.2.13'$/
  170 + assert_file "Gemfile", /^gem\s+["']mysql2["'],\s*'~> 0.2.17'$/
171 171 else
172 172 assert_file "Gemfile", /^gem\s+["']activerecord-jdbcmysql-adapter["']$/
173 173 end

0 comments on commit 4e72f59

Please sign in to comment.
Something went wrong with that request. Please try again.