Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Update ruby_version_check.

  • Loading branch information...
commit 4fa615a8661eb13d4bd8a7de4d839e9883ef26ec 1 parent 632fa15
@josevalim josevalim authored
Showing with 2 additions and 14 deletions.
  1. +0 −2  .travis.yml
  2. +2 −12 railties/lib/rails/ruby_version_check.rb
View
2  .travis.yml
@@ -1,7 +1,5 @@
script: 'ci/travis.rb'
rvm:
- - 1.8.7
- - 1.9.2
- 1.9.3
env:
- "GEM=railties"
View
14 railties/lib/rails/ruby_version_check.rb
@@ -1,8 +1,8 @@
-if RUBY_VERSION < '1.8.7'
+if RUBY_VERSION < '1.9.3'
desc = defined?(RUBY_DESCRIPTION) ? RUBY_DESCRIPTION : "ruby #{RUBY_VERSION} (#{RUBY_RELEASE_DATE})"
abort <<-end_message
- Rails 3 requires Ruby 1.8.7 or 1.9.2.
+ Rails 4 requires Ruby 1.9.3+.
You're running
#{desc}
@@ -10,14 +10,4 @@
Please upgrade to continue.
end_message
-elsif RUBY_VERSION > '1.9' and RUBY_VERSION < '1.9.2'
- $stderr.puts <<-end_message
-
- Rails 3 doesn't officially support Ruby 1.9.1 since recent stable
- releases have segfaulted the test suite. Please upgrade to Ruby 1.9.2.
-
- You're running
- #{RUBY_DESCRIPTION}
-
- end_message
end

1 comment on commit 4fa615a

Please sign in to comment.
Something went wrong with that request. Please try again.