Skip to content


Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Rails now requires rubygems 1.3.1 of higher.

  • Loading branch information...
commit 549b18c9286b6cccf4978093576325fd711dc421 1 parent c562dfc
@lifo lifo authored
Showing with 1 addition and 1 deletion.
  1. +1 −1  railties/environments/boot.rb
2  railties/environments/boot.rb
@@ -82,7 +82,7 @@ def gem_version
def load_rubygems
require 'rubygems'
- min_version = '1.1.1'
+ min_version = '1.3.1'
unless rubygems_version >= min_version
$stderr.puts %Q(Rails requires RubyGems >= #{min_version} (you have #{rubygems_version}). Please `gem update --system` and try again.)
exit 1

5 comments on commit 549b18c


This is causing problems for me on OS X 10.5.5, as I encounter the following issue: bash-3.2# gem update —system Updating RubyGems Nothing to update bash-3.2# gem -v 1.2.0


Another oddity: bash-3.2# /Library/Ruby/Gems/1.8/gems/rubygems-update-1.3.1/bin/gem -v 1.2.0




$ sudo gem install rubygems-update Successfully installed rubygems-update-1.3.0 1 gem installed $ sudo update_rubygems Installing RubyGems 1.3.0


Thanks for the tip on using update_rubygems. I figured out that 1.3.1 installed correctly when I downloaded the tarball and ran the install script. I apologize for posting here.

Please sign in to comment.
Something went wrong with that request. Please try again.