Skip to content
This repository
Browse code

Rails now requires rubygems 1.3.1 of higher.

  • Loading branch information...
commit 549b18c9286b6cccf4978093576325fd711dc421 1 parent c562dfc
Pratik authored November 14, 2008

Showing 1 changed file with 1 addition and 1 deletion. Show diff stats Hide diff stats

  1. 2  railties/environments/boot.rb
2  railties/environments/boot.rb
@@ -82,7 +82,7 @@ def gem_version
82 82
 
83 83
       def load_rubygems
84 84
         require 'rubygems'
85  
-        min_version = '1.1.1'
  85
+        min_version = '1.3.1'
86 86
         unless rubygems_version >= min_version
87 87
           $stderr.puts %Q(Rails requires RubyGems >= #{min_version} (you have #{rubygems_version}). Please `gem update --system` and try again.)
88 88
           exit 1

5 notes on commit 549b18c

William T. Nelson

This is causing problems for me on OS X 10.5.5, as I encounter the following issue: bash-3.2# gem update —system Updating RubyGems Nothing to update bash-3.2# gem -v 1.2.0

William T. Nelson

Another oddity: bash-3.2# /Library/Ruby/Gems/1.8/gems/rubygems-update-1.3.1/bin/gem -v 1.2.0

Yaroslav Markin

@wtn http://letmegooglethatforyou.com/?q=rubygems+update+to+1.3.1

Jose Fernandez

$ sudo gem install rubygems-update Successfully installed rubygems-update-1.3.0 1 gem installed $ sudo update_rubygems Installing RubyGems 1.3.0

William T. Nelson

Thanks for the tip on using update_rubygems. I figured out that 1.3.1 installed correctly when I downloaded the tarball and ran the install script. I apologize for posting here.

Please sign in to comment.
Something went wrong with that request. Please try again.