Permalink
Browse files

Enable ruby-debug only for MRI

Signed-off-by: José Valim <jose.valim@gmail.com>
  • Loading branch information...
1 parent 715f7c0 commit 5573ab2047b07c3de08d40566de8a8fc80a676cf @spastorino spastorino committed with josevalim May 19, 2010
Showing with 2 additions and 2 deletions.
  1. +2 −2 Gemfile
View
@@ -11,10 +11,10 @@ group :mri do
gem 'yajl-ruby'
gem "nokogiri", ">= 1.4.0"
- if RUBY_VERSION < '1.9'
+ if !defined?(RUBY_ENGINE) && RUBY_VERSION < '1.9'
gem "system_timer"
gem "ruby-debug", ">= 0.10.3"
- elsif RUBY_VERSION < '1.9.2' && !ENV['CI']
+ elsif defined?(RUBY_ENGINE) && RUBY_ENGINE == "ruby" && RUBY_VERSION < '1.9.2' && !ENV['CI']
gem "ruby-debug19"
end
end

2 comments on commit 5573ab2

rdp replied May 21, 2010

ruby-debug works in jruby, too...

Owner

spastorino replied May 21, 2010

yeah all jruby dependencias were added yesterday

Please sign in to comment.