Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Rename Version constant to VERSION. Closes #2802.

git-svn-id: http://svn-commit.rubyonrails.org/rails/trunk@3065 5ecf4fe2-1ee6-0310-87b1-e25e094e27de
  • Loading branch information...
commit 5cb2aa722deea44a9aac1ec2469611759a22bf75 1 parent fc51104
Marcel Molina authored
View
2  actionmailer/CHANGELOG
@@ -1,5 +1,7 @@
*SVN*
+* Rename Version constant to VERSION. #2802 [Marcel Molina Jr.]
+
* Stricter matching for implicitly multipart filenames excludes files ending in unsupported extensions (such as foo.rhtml.bak) and without a two-part content type (such as foo.text.rhtml or foo.text.really.plain.rhtml). #2398 [Dave Burt <dave@burt.id.au>, Jeremy Kemper]
View
2  actionmailer/Rakefile
@@ -9,7 +9,7 @@ require File.join(File.dirname(__FILE__), 'lib', 'action_mailer', 'version')
PKG_BUILD = ENV['PKG_BUILD'] ? '.' + ENV['PKG_BUILD'] : ''
PKG_NAME = 'actionmailer'
-PKG_VERSION = ActionMailer::Version::STRING + PKG_BUILD
+PKG_VERSION = ActionMailer::VERSION::STRING + PKG_BUILD
PKG_FILE_NAME = "#{PKG_NAME}-#{PKG_VERSION}"
RELEASE_NAME = "REL #{PKG_VERSION}"
View
2  actionmailer/lib/action_mailer/version.rb
@@ -1,5 +1,5 @@
module ActionMailer
- module Version #:nodoc:
+ module VERSION #:nodoc:
MAJOR = 1
MINOR = 1
TINY = 3
View
2  actionpack/CHANGELOG
@@ -1,5 +1,7 @@
*SVN*
+* Rename Version constant to VERSION. #2802 [Marcel Molina Jr.]
+
* Correct time_zone_options_for_select docs. #2892 [pudeyo@rpi.com]
* Remove the unused, slow response_dump and session_dump variables from error pages. #1222 [lmarlow@yahoo.com]
View
2  actionpack/Rakefile
@@ -9,7 +9,7 @@ require File.join(File.dirname(__FILE__), 'lib', 'action_pack', 'version')
PKG_BUILD = ENV['PKG_BUILD'] ? '.' + ENV['PKG_BUILD'] : ''
PKG_NAME = 'actionpack'
-PKG_VERSION = ActionPack::Version::STRING + PKG_BUILD
+PKG_VERSION = ActionPack::VERSION::STRING + PKG_BUILD
PKG_FILE_NAME = "#{PKG_NAME}-#{PKG_VERSION}"
RELEASE_NAME = "REL #{PKG_VERSION}"
View
2  actionpack/lib/action_pack/version.rb
@@ -1,5 +1,5 @@
module ActionPack
- module Version #:nodoc:
+ module VERSION #:nodoc:
MAJOR = 1
MINOR = 11
TINY = 0
View
2  actionwebservice/CHANGELOG
@@ -1,5 +1,7 @@
*SVN*
+* Rename Version constant to VERSION. #2802 [Marcel Molina Jr.]
+
* Fix that XML-RPC date/time values did not have well-defined behaviour (#2516, #2534). This fix has one caveat, in that we can't support pre-1970 dates from XML-RPC clients.
*0.9.3* (November 7th, 2005)
View
2  actionwebservice/Rakefile
@@ -10,7 +10,7 @@ require File.join(File.dirname(__FILE__), 'lib', 'action_web_service', 'version'
PKG_BUILD = ENV['PKG_BUILD'] ? '.' + ENV['PKG_BUILD'] : ''
PKG_NAME = 'actionwebservice'
-PKG_VERSION = ActionWebService::Version::STRING + PKG_BUILD
+PKG_VERSION = ActionWebService::VERSION::STRING + PKG_BUILD
PKG_FILE_NAME = "#{PKG_NAME}-#{PKG_VERSION}"
PKG_DESTINATION = ENV["RAILS_PKG_DESTINATION"] || "../#{PKG_NAME}"
View
2  actionwebservice/lib/action_web_service/version.rb
@@ -1,5 +1,5 @@
module ActionWebService
- module Version
+ module VERSION
MAJOR = 0
MINOR = 9
TINY = 3
View
2  activerecord/CHANGELOG
@@ -1,5 +1,7 @@
*SVN*
+* Rename Version constant to VERSION. #2802 [Marcel Molina Jr.]
+
* Introducing the Firebird adapter. Quote columns and use attribute_condition more consistently. Setup guide: http://wiki.rubyonrails.com/rails/pages/Firebird+Adapter #1874 [Ken Kunz <kennethkunz@gmail.com>]
* SQLServer: active? and reconnect! methods for handling stale connections. #428 [kajism@yahoo.com, Tom Ward <tom@popdog.net>]
View
2  activerecord/Rakefile
@@ -9,7 +9,7 @@ require File.join(File.dirname(__FILE__), 'lib', 'active_record', 'version')
PKG_BUILD = ENV['PKG_BUILD'] ? '.' + ENV['PKG_BUILD'] : ''
PKG_NAME = 'activerecord'
-PKG_VERSION = ActiveRecord::Version::STRING + PKG_BUILD
+PKG_VERSION = ActiveRecord::VERSION::STRING + PKG_BUILD
PKG_FILE_NAME = "#{PKG_NAME}-#{PKG_VERSION}"
RELEASE_NAME = "REL #{PKG_VERSION}"
View
2  activerecord/lib/active_record/version.rb
@@ -1,5 +1,5 @@
module ActiveRecord
- module Version #:nodoc:
+ module VERSION #:nodoc:
MAJOR = 1
MINOR = 13
TINY = 0
View
4 activesupport/CHANGELOG
@@ -1,3 +1,7 @@
+*SVN*
+
+* Rename Version constant to VERSION. #2802 [Marcel Molina Jr.]
+
*1.2.3* (November 7th, 2005)
* Change Inflector#constantize to use eval instead of const_get. [Nicholas Seckar]
View
2  activesupport/Rakefile
@@ -6,7 +6,7 @@ require File.join(File.dirname(__FILE__), 'lib', 'active_support', 'version')
PKG_BUILD = ENV['PKG_BUILD'] ? '.' + ENV['PKG_BUILD'] : ''
PKG_NAME = 'activesupport'
-PKG_VERSION = ActiveSupport::Version::STRING + PKG_BUILD
+PKG_VERSION = ActiveSupport::VERSION::STRING + PKG_BUILD
PKG_FILE_NAME = "#{PKG_NAME}-#{PKG_VERSION}"
RELEASE_NAME = "REL #{PKG_VERSION}"
View
2  activesupport/lib/active_support/version.rb
@@ -1,5 +1,5 @@
module ActiveSupport
- module Version #:nodoc:
+ module VERSION #:nodoc:
MAJOR = 1
MINOR = 2
TINY = 3
View
2  railties/CHANGELOG
@@ -1,5 +1,7 @@
*SVN*
+* Rename Version constant to VERSION. #2802 [Marcel Molina Jr.]
+
* Update to latest script.aculo.us version (as of [3031])
* Eliminate Subversion dependencies in scripts/plugin. Correct install options. Introduce --force option to reinstall a plugin. Remove useless --long option for list. Use --quiet to quiet the download output and --revision to update to a specific svn revision. #2842 [Chad Fowler, Rick Olson]
View
2  railties/Rakefile
@@ -11,7 +11,7 @@ require File.join(File.dirname(__FILE__), 'lib', 'rails_version')
PKG_BUILD = ENV['PKG_BUILD'] ? '.' + ENV['PKG_BUILD'] : ''
PKG_NAME = 'rails'
-PKG_VERSION = Rails::Version::STRING + PKG_BUILD
+PKG_VERSION = Rails::VERSION::STRING + PKG_BUILD
PKG_FILE_NAME = "#{PKG_NAME}-#{PKG_VERSION}"
PKG_DESTINATION = ENV["RAILS_PKG_DESTINATION"] || "../#{PKG_NAME}"
View
2  railties/bin/rails
@@ -12,7 +12,7 @@ end
Signal.trap("INT") { puts; exit }
require File.dirname(__FILE__) + '/../lib/rails_version'
-abort "Rails #{Rails::Version::STRING}" if %w(--version -v).include? ARGV.first
+abort "Rails #{Rails::VERSION::STRING}" if %w(--version -v).include? ARGV.first
require File.dirname(__FILE__) + '/../lib/rails_generator'
View
2  railties/lib/initializer.rb
@@ -123,7 +123,7 @@ def require_frameworks
configuration.frameworks.each { |framework| require(framework.to_s) }
end
- # Loads Rails::Version and Rails::Info.
+ # Loads Rails::VERSION and Rails::Info.
# TODO: Make this work via dependencies.rb/const_missing instead.
def load_framework_info
require 'rails_info'
View
4 railties/lib/rails_info.rb
@@ -26,7 +26,7 @@ def components
def component_version(component)
require "#{component}/version"
- "#{component.classify}::Version::STRING".constantize
+ "#{component.classify}::VERSION::STRING".constantize
end
def edge_rails_revision(info = svn_info)
@@ -70,7 +70,7 @@ def svn_info
# The Rails version.
property 'Rails version' do
- Rails::Version::STRING
+ Rails::VERSION::STRING
end
# Versions of each Rails component (Active Record, Action Pack,
View
2  railties/lib/rails_version.rb
@@ -1,5 +1,5 @@
module Rails
- module Version #:nodoc:
+ module VERSION #:nodoc:
MAJOR = 0
MINOR = 14
TINY = 3
View
4 railties/test/rails_info_test.rb
@@ -62,7 +62,7 @@ def test_property_with_block
end
def test_component_version
- assert_property 'Active Support version', ActiveSupport::Version::STRING
+ assert_property 'Active Support version', ActiveSupport::VERSION::STRING
end
protected
@@ -89,4 +89,4 @@ def assert_property(property_name, value)
property_defined? property_name
assert_equal value, properties.value_for(property_name)
end
-end
+end
Please sign in to comment.
Something went wrong with that request. Please try again.