Permalink
Browse files

Ensure queue classic is always installed above 0.3.2

Somehow travis installed queue classic 0.3.2. 0.3.2 causes the following
error:

```
1) Error:
AdapterTest#test_perform_job_logging:
URI::InvalidURIError: bad URI(is not URI?):
```

This change sets the lock file to install above 0.3.2. I'm not sure what
folks are using in production but this prevents the oldest version like
that from being installed on travis.
  • Loading branch information...
eileencodes committed Dec 8, 2017
1 parent 1b016af commit 5d9ecc1bc020a4704e9a1fca08b70f3a3e23869e
Showing with 2 additions and 2 deletions.
  1. +1 −1 Gemfile
  2. +1 −1 Gemfile.lock
View
@@ -55,7 +55,7 @@ group :job do
gem 'sidekiq', RUBY_VERSION < '2.2' ? '< 5' : nil, require: false
gem 'sucker_punch', '< 2.0', require: false
gem 'delayed_job', require: false
gem 'queue_classic', require: false, platforms: :ruby
gem 'queue_classic', '> 0.3.2', require: false, platforms: :ruby
gem 'sneakers', '< 2.0.0', require: false
gem 'que', require: false
gem 'backburner', require: false
View
@@ -277,7 +277,7 @@ DEPENDENCIES
qu-rails!
qu-redis
que
queue_classic
queue_classic (> 0.3.2)
racc (>= 1.4.6)
rack-cache (~> 1.2)
rails!

0 comments on commit 5d9ecc1

Please sign in to comment.