Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Don't need to add activerecord-deprecated_finders on edge and dev

applications

This gem will not change often to explain it be included in the
application Gemfile
  • Loading branch information...
commit 5e4683f76a30174500a4882ae7b14ad96ff11f7f 1 parent ca4bfa2
@rafaelfranca rafaelfranca authored
Showing with 1 addition and 3 deletions.
  1. +1 −3 railties/lib/rails/generators/app_base.rb
View
4 railties/lib/rails/generators/app_base.rb
@@ -115,7 +115,7 @@ def set_default_accessors!
end
def database_gemfile_entry
- options[:skip_active_record] ? "" :
+ options[:skip_active_record] ? "" :
<<-GEMFILE.strip_heredoc.chomp
# Use #{options[:database]} as the database for ActiveRecord
gem '#{gem_for_database}'
@@ -135,13 +135,11 @@ def rails_gemfile_entry
<<-GEMFILE.strip_heredoc
gem 'rails', path: '#{Rails::Generators::RAILS_DEV_PATH}'
gem 'arel', github: 'rails/arel'
- gem 'activerecord-deprecated_finders', github: 'rails/activerecord-deprecated_finders'
GEMFILE
elsif options.edge?
<<-GEMFILE.strip_heredoc
gem 'rails', github: 'rails/rails'
gem 'arel', github: 'rails/arel'
- gem 'activerecord-deprecated_finders', github: 'rails/activerecord-deprecated_finders'
GEMFILE
else
<<-GEMFILE.strip_heredoc
Please sign in to comment.
Something went wrong with that request. Please try again.