Permalink
Browse files

added tip about ruby-debug needing a different gem if using 1.9 [#190

…state:resolved]
  • Loading branch information...
1 parent b0aae28 commit 6492a2bd2198e38f374611b7c10fd976a2867b29 @robzolkos robzolkos committed Oct 24, 2010
Showing with 2 additions and 0 deletions.
  1. +2 −0 railties/guides/source/debugging_rails_applications.textile
@@ -225,6 +225,8 @@ The debugger used by Rails, +ruby-debug+, comes as a gem. To install it, just ru
$ sudo gem install ruby-debug
</shell>
+TIP: If you are using Ruby 1.9, you can install a compatible version of +ruby-debug+ by running +sudo gem install ruby-debug19+
+
In case you want to download a particular version or get the source code, refer to the "project's page on rubyforge":http://rubyforge.org/projects/ruby-debug/.
Rails has had built-in support for ruby-debug since Rails 2.0. Inside any Rails application you can invoke the debugger by calling the +debugger+ method.

0 comments on commit 6492a2b

Please sign in to comment.