Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Merge pull request #10222 from senny/update_bundler_section_in_assets…

…_guide

docs, adjust the application.rb snippets to match the generated file.

Closes #10449
  • Loading branch information...
commit 6f70463547191f25065f630addd4356ad5384f81 1 parent 8f241cb
Rafael Mendonça França rafaelfranca authored
Showing with 7 additions and 9 deletions.
  1. +7 −9 guides/source/asset_pipeline.md
16 guides/source/asset_pipeline.md
View
@@ -815,18 +815,16 @@ end
If you use the `assets` group with Bundler, please make sure that your `config/application.rb` has the following Bundler require statement:
```ruby
-if defined?(Bundler)
- # If you precompile assets before deploying to production, use this line
- Bundler.require *Rails.groups(:assets => %w(development test))
- # If you want your assets lazily compiled in production, use this line
- # Bundler.require(:default, :assets, Rails.env)
-end
+# If you precompile assets before deploying to production, use this line
+Bundler.require *Rails.groups(:assets => %w(development test))
+# If you want your assets lazily compiled in production, use this line
+# Bundler.require(:default, :assets, Rails.env)
```
-Instead of the old Rails 3.0 version:
+Instead of the generated version:
```ruby
-# If you have a Gemfile, require the gems listed there, including any gems
+# Require the gems listed in Gemfile, including any gems
# you've limited to :test, :development, or :production.
-Bundler.require(:default, Rails.env) if defined?(Bundler)
+Bundler.require(:default, Rails.env)
```
Please sign in to comment.
Something went wrong with that request. Please try again.