Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Rack dependency bumped to 1.1.0, tests passing. [#3558 state:resolved]

Signed-off-by: José Valim <jose.valim@gmail.com>
  • Loading branch information...
commit 74206aeff2b6a960612a820ec47e91ef9b778262 1 parent 5b1f4c5
@rizwanreza rizwanreza authored josevalim committed
Showing with 2 additions and 2 deletions.
  1. +1 −1  actionpack/Rakefile
  2. +1 −1  actionpack/lib/action_controller.rb
View
2  actionpack/Rakefile
@@ -80,7 +80,7 @@ spec = Gem::Specification.new do |s|
s.requirements << 'none'
s.add_dependency('activesupport', '= 2.3.6' + PKG_BUILD)
- s.add_dependency('rack', '~> 1.0.0')
+ s.add_dependency('rack', '~> 1.1.0')
s.require_path = 'lib'
s.autorequire = 'action_controller'
View
2  actionpack/lib/action_controller.rb
@@ -31,7 +31,7 @@
end
end
-gem 'rack', '~> 1.0.1'
+gem 'rack', '~> 1.1.0'
require 'rack'
require 'action_controller/cgi_ext'

5 comments on commit 74206ae

@TMorgan99

Hello.
Where are your test for this - I have a failing example.
I can run selenium test in rails 2.3.5, but upgrading to 2.3.8 gives error.
A git bisect search tags this as the first failing commit.
Reversing this patch in 2.3.8 restores my test.

https://rails.lighthouseapp.com/projects/8994/tickets/4714-rails-238-breaks-selenium-test

@radar

I too have the same issue but with flash notices on 2.3.8, it turns out it is to do with Authlogic. Check out my repo at http://github.com/radar/rails-test-app

@radar

I'm curious TMorgan: How would you test a change like this?

@jdelStrother

I also ran into problems with this in integration tests - my session was no longer persisting. It seemed like my session key was getting prepended with a newline on the Set-Cookie response, so the next request would send the cookie like :
"\nmyapp_session" => "BAh7BjoPc2Vzc2lvbl9pZCIlOWQ2OGU1OTE5M2NkOWZ4NjAwNmJlZmFmNjA0NWNhYTA%3D--bc5ae2eb9cde54b32ae63928f30e20b105483a1c"

@jstorimer

I opened up a lighthouse ticket with a patch that resolved the issue for me. Please review.

https://rails.lighthouseapp.com/projects/8994/tickets/4743-session-cookie-breaks-if-used-with-custom-cookie-in-rails-238

Please sign in to comment.
Something went wrong with that request. Please try again.