Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Add note about installing and running Memcached for Rails test suite …

…tests that depend on it. [ci skip]
  • Loading branch information...
commit 7889e3da6c3f41ecff7dc6075a6fce9c597d56be 1 parent 5c6e11d
@pawel2105 pawel2105 authored
Showing with 23 additions and 1 deletion.
  1. +23 −1 guides/source/development_dependencies_install.md
View
24 guides/source/development_dependencies_install.md
@@ -113,7 +113,29 @@ and run:
$ bundle install --without db
```
-This command will install all dependencies except the MySQL and PostgreSQL Ruby drivers. We will come back to these soon. With dependencies installed, you can run the test suite with:
+This command will install all dependencies except the MySQL and PostgreSQL Ruby drivers. We will come back to these soon.
+
+NOTE: If you would like to run the tests that use memcached, you need to ensure that you have it installed and running.
+
+You can use homebrew to install memcached on OSX:
+
+```bash
+$ brew install memcached
+```
+
+On Ubuntu you can install it with apt-get:
+
+```bash
+$ sudo apt-get install memcached
+```
+
+Or use yum on Fedora or CentOS:
+
+```bash
+$ sudo yum install memcached
+```
+
+With the dependencies now installed, you can run the test suite with:
```bash
$ bundle exec rake test
Please sign in to comment.
Something went wrong with that request. Please try again.