Permalink
Browse files

Removed rescue branch for Rails 2.x compatibility

  • Loading branch information...
1 parent ca04411 commit 78cd3f9ec262a6da8283a6ec95751a0bcd776051 @gazay gazay committed Jun 20, 2011
Showing with 0 additions and 3 deletions.
  1. +0 −3 railties/lib/rails/generators.rb
@@ -299,9 +299,6 @@ def self.lookup(namespaces) #:nodoc:
return
rescue LoadError => e
raise unless e.message =~ /#{Regexp.escape(path)}$/
- rescue NameError => e
- raise unless e.message =~ /Rails::Generator(\s|::|$)/
- warn "[WARNING] Could not load generator #{path.inspect} because it's a Rails 2.x generator, which is not supported anymore. Error: #{e.message}.\n#{e.backtrace.join("\n")}"
rescue Exception => e
warn "[WARNING] Could not load generator #{path.inspect}. Error: #{e.message}.\n#{e.backtrace.join("\n")}"
end

0 comments on commit 78cd3f9

Please sign in to comment.