Skip to content
This repository
Browse code

Allow Thor 0.15 and 1.0, to be released shortly

  • Loading branch information...
commit 7dc83f78232a6dfcdd70292e831403933f57347b 1 parent 86559be
authored April 28, 2012

Showing 1 changed file with 5 additions and 1 deletion. Show diff stats Hide diff stats

  1. 6  railties/railties.gemspec
6  railties/railties.gemspec
@@ -21,8 +21,12 @@ Gem::Specification.new do |s|
21 21
   s.rdoc_options << '--exclude' << '.'
22 22
 
23 23
   s.add_dependency('rake',          '>= 0.8.7')
24  
-  s.add_dependency('thor',          '~> 0.14.6')
25 24
   s.add_dependency('rack-ssl',      '~> 1.3.2')
  25
+
  26
+  # The current API of the Thor gem (0.14) will remain stable at least until Thor 2.0. Because
  27
+  # Thor is so heavily used by other gems, we will accept Thor's semver guarantee to reduce
  28
+  # the possibility of conflicts.
  29
+  s.add_dependency('thor',          '>= 0.14.6', '< 2.0')
26 30
   s.add_dependency('rdoc',          '~> 3.4')
27 31
   s.add_dependency('activesupport', version)
28 32
   s.add_dependency('actionpack',    version)

4 notes on commit 7dc83f7

José Valim
Owner

Scumbag @wycats, changes Thor semantically from 0.14 -> 0.15, commits to Rails 3-2-stable saying Thor will guarantee semver. :trollface:

Nikos Dimitrakopoulos

What are the chances of bringing this back to 3.1.X? 0%???

Rafael Mendonça França

@nikosd unfortunately none. 3-1-stable is not under maintenance anymore. This branch only accepts security fixes

Nikos Dimitrakopoulos

I imagine that :)

Please sign in to comment.
Something went wrong with that request. Please try again.